New Installation

Just came on board at a small business and there was FreePBX system recently installed with Cisco IP phones on each desk. Was using a Google Voice service but switched over to Broadvoice SIP service. We are experiencing intermittent issues with calls where they seem “jittery”. Haven’t had any drop completely but bad enough had to call someone back using my cell phone. Its not every call but happens fairly often.

If I am not in the right spot to post this please let me know and I will change. Ia m just looking for some suggestions on if the problem may be in my PBX configuration, the IP phones, the connection through my SIP provider? We have a 35x5 MB internet connection via cable modem. it is shared but consistently are getting 9-10MB down and 5MB up. So I feel like the problem may be either a PBX setting or Phone setting but I don’t know for sure. We only have 20 IP phones here in the office.


Steve - Was this response not acceptable to you? You posted the same message again. We prefer only 1 post per topic per user so I removed your second post.

Also, there are no settings that could cause what you are saying, either your carrier is marginal in the areas you are calling or your Internet connection is deficient. There is a small chance that the phones could have negotiated half duplex.

All of this has been covered but let’s review it again:

1 - Enable SNMP on your router and capture statistics, guess is meaningless you need data

2 - If you have a managed switch check each port to make sure full duplex and that you are not getting any errors.

3 - Run an MTR from your server to your carrier for a day and see how the connection looks from your servers perspective.

4 - Do the impaired calls correspond with times you have high call volume or network usage?

Sorry about the second post. Thanks for the suggestions. I will check and see what I find.


As a person who used cable for several years with Trixbox then FreePBX, I can tell you we used to experience the same thing. You can get jitter while still having plenty of bandwidth left as bandwidth does not measure how quickly a packet gets to you, just how many packets you can get. In our case, we increased the jitter buffer size which nearly eliminated the problem. If you make the buffer too big however, you have a delay in the conversation and start talking on top of each other.

From GUI ->Settings-> Asterisk IAX Settings-> come down to Jitter Buffer Settings. Enable Jitter Buffer. Play with Jitter Buffer size, try about 200.