New install - various inconsistent issues - pulling my hair out!

I’m rolling out a new system for a client. This will be my 10th FreePBX install in place and working (all other sites no issue, including my own office).

I have a 4 phone system that I just setup for a new client (not live yet). We have a separate network and firewall just for the phones. Everything is configured correctly (even went page by page and matched against a working setup to make sure), but I keep getting completely random issues. These issues include

-Outgoing calls randomly will not disconnect if the recipient hangs up or rejects the call
-Incoming calls randomly just sit silent (from the caller perspective) and eventually hang up
-Outgoing calls randomly just don’t work at all
-Lots of strange errors in the log (keep in mind this is a brand new system)

Overall I just can’t get this system to a stable place. They have an identical Firewall to what I have in my own office and I’ve matched our ALG settings (my office has been up for months with no downtime or issues such as this). Never the less…I’ve played with the ALG settings as well just to see if that was the issue.

Here is the setup:
-VITELITY for VOIP provider
-Latest FreePBX distro with all stable updates
-Yealink T46G phones
-Gigabyte Brix with i3 processor, 4GB Ram and Solid state drive
–Network is hardwired directly to the firewall
-All phones connect to a TPlink POE switch for power and data
–switch is hardwired to firewall

Inbound route goes like this:

  1. Time conditions check for M-F condition
    –If match go to Open Hours IVR
    –If no match go to Time Conditions and check if it’s Saturday
    —If Saturday, go to Open Hours IVR
    –If NO match (after hours, Sunday) go to After hours IVR
  2. IVRs (in both cases) have a few options
    –Press 1 to hear hours, 2 to talk (dials ring group of all phones), 3 to leave a message

When it WORKS everything works beautifully. It just seems that getting the initial calls in, out, and stable are the problem. I’ve put in a lot of hours and I can’t seem to narrow it down to any one particular issue. I’m happy to post log files…anything I can do for help. I appreciate the time of all the members of this forum! I’m really hoping there is something simple I’ve just missed through all my frustrations!.

Thank you

At this point I’m considering wiping this setup and starting from scratch. Anyone out there have any ideas before I do?

I would have to suggest that if nine out of ten installations have worked fine, then either this particular network is actually different or the install media was different or corrupt, if the reinstall still doesn’t work then the only thing left is the network, there are no other variables. You would need to post logs of what is not working, not what you think should work, or it would be just guesswork, no?

Thanks for the reply. The network should be solid (new wires, all tested, brand new POE switch, brand new firewall). I suppose it’s wipe and reinstall time…

Well, that would be the first step if you suspect your method.

If that doesn’t work then post some substantive logs as to what doesn’t work.

Is there a guide on this forum for best practices in posting logs?

It’s in the wiki . . …

1 Like