New Install Not Registering Device

So i just installed Asterisk and FreePBX. I am also using Zoiper and trying to get 2 computers to dial each other.

Only thing apart from installing the system i have done is open up ports 5060 and 5061 to point to the Asterisk server.

My Asterisk server is on a VM on the main server.

In zoiper it looks like i register. My login has a green check and i have an unregister option in the settings. This is for both users i have set up. However, i cannot call either computer.

I also have been unable to use the extension to create an extension or user that zoiper can connect with. The only way i was able to get Zoiper to connect to the system was mofiying the config files inside Admin->ConfigEdit

is there some simple step 1 or 2 i have missed in all the how-to guides i have read for quick setups? below are my mods to the conf files. i also did the fwconsole restart a couple times

inside extensions.conf

inside pjsip.conf

;Templates for the necessary config sections




;Definitions for our phones, using the templates above


and finally inside sip.conf




Start with wiki linked at the top of this page.

After doing that, read the first few lines of the files you modified to see why it ‘won’t work’

Everything you are trying to do is really quite trivial after a bit of “RTFM’ing”

i went through the manual a couple time. and if you are referring to the extensions being the same number. they are not in the real application. that was a copy paste here error. the extension to user2 is 1002.

After editing those files, look in them again after ‘reloading’ freepx.

sorry when i said i updated the sip.conf file I didnt update the actual config files. i updated the sip_custom.conf files that are referenced from within the do not edit sip.conf file

I tried doing it from the GUI at first and got even less far. I added the extension and created a user and Zoiper cannot even connect. i would link the wiki page i was using as a guide but just made account and they wont let me

Le tme ask this. Should all i have to do is open the ports and add an extension within the GUI to be able to sign in with Zoiper? I have tried to use the CHAN_SIP and CHAN_JPSIP options and neither one lets Zoiper connect

Sorry, haven’t read that guide, but if you are doing custom stuff, you will need to

dialplan reload

for anything to take. (Yep, it’s in the manual :slight_smile: )

Best advice, don’t do the custom stuff yet, just do the baby steps thing.

As @dicko says. At this stage, don’t even think about custom code. Start over with a clean install.

Assuming that the extensions and FreePBX are on the same LAN subnet and the VM is set up for bridged networking, there should be nothing to open. (When you get around to setting up SIP trunks, some forwarding may be needed.)

Create one pjsip extension. Configure Zoiper to use the extension number and the secret generated by FreePBX. If Zoiper doesn’t register, stop and find out why. If it does, try calling the echo test on *43. If you get no audio, stop and find out why. If that works, create a second extension and test in the same way. Once you get that far, you should be able to call between them.

Are you new to phones systems?

Even if you are not new, why would you install asterisk and then FreePBX? While there are use cases, it is small unless you just have to be on your own OS flavor for some crazy reason.

If you are going to use FreePBX, use the distro unless you actually know what you are doing.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.