New install Freepbx with Yearlink T21p phone - voice message not blinking?

I have decided to give Freepbx a go and installed the latest version of freepbx with some yearlink t21p phone. Everything is working, I was able to make inbound call and outbound. For some reason when I leave a message for an extension, their phone message button do not flash . What is the best way to troubleshoot this?

The voice message is working because if i pick up the phone and dial *97. I was able to hear there are new message for me.


This most likely requires that the voicemail field have *97 in it.
On the 4 series phones it’s under account>advanced. I’m not sure about the 2 series.

thanks for your reply. on the phone i went to account -> Advanced. and I do see voicemail: *97
and save it and I leave myself a voicemail but the light doesn’t flashes. Anywhere to see why the flashing is not appearing?

I have also enable “Subscribe for MWI” and “Subscribe MWI to VM” in the webpage also checked the power voice/text message led enable

What is the voicemail inbox in your extension options?

PJSIP or chan_sip extension? If PJSIP, edit the extension and look for MWI Subscription Type on the Advanced tab and toggle the setting there.