New install AsteriskNow to POTS line, no inbound or outbound calls

Hello everyone,

Let me warn you first off I am extremely new to this whole process of using FreePBX/Asterisk and am ok in Linux. I installed AsteriskNow from the Digium company website on a server with a TDM808 telephony card, and have run two POTS lines to the card for testing purposes. I have gone thru the steps and configured everything following the instructions provided on this website. I have triple checked to verify all settings are as suggested. When I attempt to call out (using an X-lite softphone), I am getting a 503 - Service Unavailable error. When I call into one of the specific lines, I get a few rings, then a recorded message saying “Bye” and a hangup.

I am currently running CentOS v 5.5 on the server, with Asterisk v 1.6.2.11. The FreePBX is currently at v 2.9.0.7. All installation settings were done by The server detects that the card is installed, and recognizes it when I do a lspci i get the following results:

03:0b.0 Ethernet controller: Digium, Inc. Wildcard TDM800P 8-port analog card (rev 11)
Subsystem: Digium, Inc. Wildcard TDM800P 8-port analog card
Flags: bus master, medium devsel, latency 32, IRQ 3
I/O ports at dc00
Memory at dfbffc00 (32-bit, non-prefetchable)
Expansion ROM at dfc00000 [disabled]
Capabilities: [c0] Power Management version 2

Also when doing a dahdi_scan I get:
[[email protected] ~]# dahdi_scan
[1]
active=yes
alarms=OK
description=Wildcard TDM800P Board 1
name=WCTDM/0
manufacturer=Digium
devicetype=Wildcard TDM800P (VPM100M)
location=PCI Bus 03 Slot 12
basechan=1
totchans=8
irq=233
type=analog
port=1,FXO
port=2,FXO
port=3,FXO
port=4,FXO
port=5,FXO
port=6,FXO
port=7,FXO
port=8,FXO

The only ports currently in use are 1 and 2, which have POTS lines, which are attached to a punch and then run from the outside PSTN lines.

Any help on this would be GREATLY appreciated.

I am now able to call outbound, but still unable to call inbound. Here is a call log from when i attempt to call into the line. Please advise.

– Starting simple switch on ‘DAHDI/8-1’
== Starting DAHDI/8-1 at XXXXXXXXXX,s,1 failed so falling back to exten ‘s’
== Starting DAHDI/8-1 at XXXXXXXXXX,s,1 still failed so falling back to context ‘default’
– Executing [[email protected]:1] Playback(“DAHDI/8-1”, “vm-goodbye”) in new stack
– <DAHDI/8-1> Playing ‘vm-goodbye.ulaw’ (language ‘en’)
== Manager ‘admin’ logged on from 127.0.0.1
– Executing [[email protected]:2] NoOp(“DAHDI/8-1”, “ERROR: FreePBX Does not use the [default] context, confguration error”) in new stack
– Executing [[email protected]:3] Macro(“DAHDI/8-1”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“DAHDI/8-1”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] Hangup(“DAHDI/8-1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘DAHDI/8-1’ in macro ‘hangupcall’
== Spawn extension (default, s, 3) exited non-zero on ‘DAHDI/8-1’
– Executing [[email protected]:1] Macro(“DAHDI/8-1”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“DAHDI/8-1”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] Hangup(“DAHDI/8-1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘DAHDI/8-1’ in macro ‘hangupcall’
== Spawn extension (default, h, 1) exited non-zero on ‘DAHDI/8-1’
– Hungup ‘DAHDI/8-1’

Any help would be greatly appreciated!

bump it up, need some help plz

What is your inbound route? You can get fancy with Inbound> Call Flow> Time Cndition> IVR later. For now just send all inbound calls to a known working extension.

You may also want to post your /etc/asterisk/chan_dahdi.conf so peeps can check it out, although since you can make outbound calls it is probably good.

My inbound route is set to accept ., so its just a catch-all route. Like I said, test calls ring and then I get a goodbye sound file.

Some ideas and clarifications…

Is it ringing the extension though? I’m not referring to what you hear on your calling phone/cell phone, I’m referring to the softphone - do you see/hear it ring there?

Do you have a VoIP phone you can plug in for testing?

I don’t know X-lite softphone, I use the BOL SipPhone (older version is free), the config notes are very helpful and may be something you can cross check in X-Lite (the big picture will still be the same although the implementation will be different)

I have no idea what ‘inbound route is set to .,’ means is that cfg file you’re looking at? I’m no uber Asterisk guy and try to use the GUI whenever possible, under Inbound Route what is your ‘Set Destination’ value, an IVR, an extension?

Can you build a quick and dirty IVR, set the Inbound to that to see if you still get dropped? Don’t bother with the voice recordings, just make an option 1 and 2 pointing to different extensions, then when you dial in press those options to see what happens

Im sorry I didnt clarify. The . signifies a wildcard in the dial plan, basically it will search for anything in the dial string. I had it set so ANY calls will be forwarded to my test extension which is on my softphone. The softphone itself never rings. I didn’t mess with any configuration setting in X-lite besides just registering it to my asterisk server so that it can make calls.

As far as IVR, I havent even touched that mess yet because I wanted to get the in and out working before further complicating things.

It still sounds like an Inbound Route issue to me. In the GUI, I cannot find any reference to a Dial Plan for the Inbound Route, Trunk, or Outbound Trunk. Since you’re using the phrase dial plan that makes me think you’re not looking at anything inbound. Again, if this is a config file somewhere, mention the name and path and I can check it out. Otherwise in the GUI, under Inbound Route what is your ‘Set Destination’ value equal to?

There are Dialing Rule/Plans settings in Trunks and Outbound Routes. For basic setups the I leave trunks fairly empty and add all of my outbound dialing patterns I add/edit in the Outbound Route.

What context do you have the FXO ports in? Do a ‘dahdi show channels’ from the Asterisk CLI.

Also capture the log when a call comes in and post the output either with the code tags (see input format) or post a link to pastebin.ca

Here is the CLI log when the call comes in:

-- Starting simple switch on 'DAHDI/8-1'

== Starting DAHDI/8-1 at ,s,1 failed so falling back to exten ‘s’
== Starting DAHDI/8-1 at ,s,1 still failed so falling back to context ‘default’
– Executing [[email protected]:1] Playback(“DAHDI/8-1”, “vm-goodbye”) in new stack
– <DAHDI/8-1> Playing ‘vm-goodbye.ulaw’ (language ‘en’)
– Executing [[email protected]:2] NoOp(“DAHDI/8-1”, “ERROR: FreePBX Does not use the [default] context, confguration error”) in new stack
– Executing [[email protected]:3] Macro(“DAHDI/8-1”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“DAHDI/8-1”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] Hangup(“DAHDI/8-1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘DAHDI/8-1’ in macro ‘hangupcall’
== Spawn extension (default, s, 3) exited non-zero on ‘DAHDI/8-1’
– Executing [[email protected]:1] Macro(“DAHDI/8-1”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“DAHDI/8-1”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] Hangup(“DAHDI/8-1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘DAHDI/8-1’ in macro ‘hangupcall’
== Spawn extension (default, h, 1) exited non-zero on ‘DAHDI/8-1’
– Hungup ‘DAHDI/8-1’

Here is the dahdi show channels:

*CLI> dahdi show channels
Chan Extension Context Language MOH Interpret Blocked State
pseudo default default In Service
1 default In Service
2 default In Service
3 default In Service
4 default In Service
5 default In Service
6 default In Service
7 default In Service
8 default In Service

As I noticed in the Zap Channel DIDs section, I attempted to find the files they listed to change the context to from-zaptel, but the zaptel.conf and other files couldn’t be found. Seeing as how this is most likely the issue I am running into, is there anything I am overlooking?

Did you notice this?

"ERROR: FreePBX Does not use the [default] context, confguration error") in new stack
-- Executing [[email protected]:3] Macro("DAHDI/8-1", "hangupcall") in new stack

As I indicated you context is wrong.

Change to from-zaptel the config file is for the DAHDI driver. Look at /etc/asterisk/chan-dahdi.conf and the includes.

Yes I had noticed it, but because I couldn’t find the location of the zaptel.conf file I was at a loss.

My chan_dahdi.conf file consists of:

; Copied from DAHDI Module of FreePBX

[general]

; generated by module
#include chan_dahdi_general.conf

; for user additions not provided by module
#include chan_dahdi_general_custom.conf

[channels]

; for user additions not provided by module
#include chan_dahdi_channels_custom.conf

; include dahdi groups defined by DAHDI module of FreePBX
#include chan_dahdi_groups.conf

; include dahdi extensions defined in FreePBX
#include chan_dahdi_additional.conf

Is there a specific way to arrange the from-zaptel context? Im a bit lost here.

Looks like you never ran your ‘dahdi_cfg -vv’ that generates a chan_dahdi.conf file where you set your context. The location of the file is listed in my first post, although I think they made it a symbolic link to /var/~something~/~something~ in FreePBX 2.9

You may want to review http://www.cadvision.com/blanchas/Asterisk/ That was the most helpful doc for me when I started.

So Skyking, not to hijack the thread, but when should you use zaptel vs pstn for the context? I was never clear on that.

What I did (in pbxinaflash) is to go into the Dahdi menu, click the edit section. In there, the context box was empty (apparently after an automatic update during the night.)

I put from-zaptel in the context box for each fxo port and now the calls come in normally.

I’m new too to this whole thing… i cant make or receive calls using the fxo line, i did change the context like you mentioned in the last entry of this thread, it was empty… but i cant find the “chan_dahdi.conf” file…

i also notice that when i go in FreePBX to the DAHDI tab, on the very top i see a small message that says “Install chan_dahdi.conf” …

the fxs extensions are working fine, but i really dont know enough about this so i dont know if i need to click on the install chan_dahdi.conf option or not…

help???

I can’t believe anyone hasn’t said this, But AsteriskNOW is pretty outdated. You should consider the FreePBX Distro or PBX In A Flash.

I prefer FXO Gateways, and so I can’t help you with Dahdi

did you ever get this figured out?

I just downloaded and installed a new Distro and DAHDI COnfig module, and my Rhino FXO 4-port card was working in approximately 5 minutes… Granted, this was a basic config, but even so, I’d urge anyone dealing with POTS to give it a whack. I thought it was spectacular.