New install and module admin

I have done a new install of 1.1100.211.63 (x86)in a VMWare Desktop VM and noticed that the sysadmin module is now no longer installed automatically.
Have gone into module admin and selected Basic, Extended and Commercial and told System Admin to install.
After clicking confirm, it starts the install and then hangs on LoadLicenseIfExisits.php (have left it there overnight).
In a previous snapshot i just clicked the x on the top right and then went back into module admin and it was in the list as locally available but not installed.
Told it to install again and this time it picks up from where it left off and installs fine.
Module installing is
After this it works fine but wondering why the double install?
Also, when trying to install the Schmooze Endpoint Manager it just hangs on Please wait while module actions are perfomed.
had a look around but could not see this posted anywhere before.
Also, is there any way to install FOP2 on this version?
Have been running it fine on 1.8xxx.58

1.1100.211.63 is a Beta build so odd stuff is going to happen thanks for reporting, there are some known quirks with CENTOS 6.3 on virtual platforms. I know most of the developers will check out the forums, but you may want to submit a ticket here to get the most visibility and feedback from the developers:

Concerning the Schmooze Endpoint Manager:

A) it’s in private beta at this point so installation would not work properly as it requires some extra steps to implement until we publicly launch it in the marketplace.

B.) once launched it will require a license like any of the other Pro Modules and will not work until licensed.

We announced that we would be launching the EPM PRO module at Astricon, The EPM PRO module will be a commercially supported EPM, we are using this EPM in our PBXact and PBXtended line of products at this time, we are just doing our due diligence on making sure that EPM is production ready for a standard FreePBX install, as our commercial platforms have a lot of add ons and customization that are not included in the Distro.

Is this still an issue 6 months on??? I just tried to install EndPoint Manager and I get the same error as above. The module downloaded and extracted, and the module manager is reporting that it is available locally. However when I attempt to install it, it just hangs with the message “Please wait while module actions are performed”. Is there a workaround for this?

System is Centos 6.4 X64 (AsteriskNow 3.0)

No it’s working fine for several other people. Is there a reason you choose AsteriskNow 3.0? That’s probably your issue

End Point Manager is a commercial module and requires some manual setup on AsteriskNow. Please see

Hi Tony,

I am aware that End Point Manager is a commercial module, and I had already followed the instructions in the link that you sent.

The prerequisites installed correctly as did the Sysadmin module. My installation is also registered in your license server. Despite this the Endpoint module will not install. I have not at this time actually paid for a license for this module yet. I was working on the assumption that it would be possible to install it and then buy the license, could this be the issue? If so, the document that you referenced did not indicate that this was the case. How would you suggest that I proceed?

Each time an attempt is made to install the commercial Endpoint Manager the freepbx_dbug log shows the following entry:

2013-Jul-03 15:45:11 /var/www/html/admin/libraries/module.functions.php:1506
[WARNING]: Invalid argument supplied for foreach()

Do you have the OSS End Point Manager installed?

Attempts to install the endpoint manager from the command line using module_admin fail with the following errors:
/usr/src/freepbx-2.11.0beta2/amp_conf/bin/module_admin install endpoint

PHP Fatal error: Cannot redeclare endpoint_systype() (previously declared in /var/www/html/admin/modules/endpoint/ in /var/www/html/admin/modules/endpoint/ on line 0

Yes, the OSS Endpoint Manager is installed. Should this be removed first?

Sure looks like a bug to me. I have also noted that this is a new build from 8 days ago, (June 25th).

Yes the conflict with each other.