New install *1.4.11 freepbx 2.3.0

Everything install without errors. Very smooth. I was amazed. Now I’m attempting to use FF 2.0.0.6 to connect to freepbx. I can get the main page with the 3 options. If I select any of the options FF immediately does a file download. I have tried two other browsers; IE and Maxthon2. Same result. I was able to look at the download. It looks to be the contents of the index.php file.

I’m not a linux guru I just know enough to get around. I was reading other posts and it seems the problem might be PHP5. Which I have installed. I didn’t understand from the other posts how to fix the problem. Something about an “interpreter” change.

I don’t know if this is the problem or not. Please help! I have spent a lot of time trying to figure this out on my own.

hi:
it sound like you didn’t install the apache-mod_php. so your apache web server don’t know how to execute php scripts.so it just send you php content like html files. just install apache-mod_php to link your apache and php and you will be fine . i use 1.4.11+2.3.0+php5.0+ff 2.6. just like you.

Is apache-mod_php the same thing? I can’t find it to install if apache-mod_php is the name.

I’m using ubuntu 7.04 server. This may be the reason I can’t find it. I’m using apt-get install. It tells me the package doesn’t exist.

On ubuntu, it’s called libapache2-mod-php5. Run:

apt-get install libapache2-mod-php5

and it should get everything it needs. There’s a wiki page UbuntuServer that might help you out.


Greg MacLellan - Core freePBX Developer
http//freepbx.org - irc.freenode.net #freepbx

I already had libapache2-mod-php5 installed. After reading many post on different sites.

I copied php5.conf and php5.load from mods-available to mods-enabled. I also did a apt-get install php5-cgi.

restarted apache2 and finally things worked. 3 damn days of banging my head.

Thanks, I added that to the wiki. The actual proper way is to use “a2enmod php5” which symlinks the files into mods-enabled. If the php5 package upgrades those files, you don’t have to worry about it.

You don’t need php5-cgi at all though.


Greg MacLellan - Core freePBX Developer
http//freepbx.org - irc.freenode.net #freepbx

I installed Trisbox from the donwloadable ISO.

It all goes just fine during the installatin but whe I change AUTHTYPE= from “none” to "database I loose access to the “amportal”. I verify the settings on the amportal.conf and run the “apply_conf.sh” and even reboot the server but the only way I can get back on the amportal (freepbx) pages is by changing the AUTHTYPE= back to “none” .

I have "Freepbs 2.3.3 and Feature Code Admin 1.0.5.3 (Asterisk 1.4.10.1) and all of this under Redhat.

Is amportal reliable? I’m very new (the newest) Linux user and I’m sure it is something I don’t understand. Any help anyone???

you probably need to turn off the apache authentication which trixbox sets up for you and is in your apache files.

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx