New FreePBX Installation, Vlan + Mikrotik Router, Phones not connecting

Hi Everyone,

Long time asterisk user, well hobbyist and just started a new business so wanted to get our own internal PBX online.

Installed FreePBX to see how the Web GUI worked and soo far I am impressed. I think for a business application having the web gui for other guys in the office to use is easier than working directly with Asterisk Modules.

Installed FreePBX and complted set up, created extensions and connected a Cisco 303 ip phone. No connection. I admit I then decided to format the server and re-install just asterisk… Same problem.

My current network set up is a Mikrotik Router which has 6 Vlan networks, connected to a Cisco Switch which directs the Vlan’s to different ports.

The mikrotik has Nat rules set up to forward 5060 and 10000-20000 to the asterisk box, but still no luck. On the Cisco phone I am getting “Not Registered” or cannot connect to server.

Server is on Vlan 144, subnet, and Phones are on Vlan 122 subnet

Not sure what the issue could be currently, I can access the phones admin pages from a different vlan, and ping the phones from the asterisk box.

Any help would be appreciated!


Do you have both networks defined in SIP settings/localnet?

Hi, Thanks for the reply,

I have set up all the local networks in the localnet fields, adding each local subnet and the router ip, still no luck

You might want to consider adding the various “tagged” vlans to your server’s ethernet interface if it supports the tagged frame size (only very old hardware doesn’t) and eliminate the Cisco “untagging” You will then have direct access to all your hardware.

Thanks for the reply, I will look into that now, might also fix the printer issues I have been having!