New FreePbx Installation Calls without Audio

i´m new to the FreePbx and just want to learn about it. Just installed FreePbx two times. First a raspbx on an Raspi3 direct connected to my home network. Then the official freePbx iso in an VirtualBox with bridged network.
I used some youtube video tutorials for first install an configuration. They are named " Themenreihe FreePBX 15/Asterisk 16"
I have an Fritzbox7590 as router and a standard german telekom allip connection. After doing all like described in the videos (1-3) i can do internal calls (the connection is established) between a softphone installed on my cell phone and a snom d715. i can also make a outbound call from the softphone to a cell phone on the gsm network. But all calls are without audio on both sides.
At first i thought the raspbx image is the problem, so i installed it once more in the virtualbox with the iso. But the problem is still the same.
What i did so long to solve the problem:

  • Tried to set the ip of the freepbx as a exposed host in the fritzbox to avoid problems with the internal firewall of the fritzbox
  • Changed “Direct Media” to yes in Trunk > pjsip-settings
  • Set in the /etc/asterisk/pjsip.endpoint_custom_post.conf
    direct_media=no for the extensions

Nothing helps. So i hope you can help me or give me some hints.
I wanted to share my logs with you via google drive. But the system says that t is not allowed to share links as a new user :frowning:

Thanks in advance,

Don’t make any custom config file changes until your system is working and you understand what you are doing. If you are running current FreePBX 15 / Asterisk 16, you should see on the Advanced tab for a pjsip extension a Direct Media parameter, which defaults to No, so direct media should already be off.

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change these, you must restart Asterisk.

If you still have trouble, at the Asterisk command prompt (not a shell prompt), type
pjsip set logger on
the response should be
PJSIP Logging enabled
make a failing test call from one extension to another, paste the Asterisk log (not the console log) for the call at and post the link here. If you still can’t post links, put the link text between ` characters, for example


If for some reason you need to post a link to content hosted elsewhere, choose a service that does not require the reader to log in. Many regulars on this forum do not like to be tracked and won’t open such links.

Whoo, what a fast response. Many thanks.
Yes, the Ip Settings under general SIP settings > NAT-Settings are absolutely right.

I restartet the freepbx, enabled logging and made a test call. Further with no audio.
I hope i get the right logfile. It´s the full from /var/log/asterisk/
Shorten it a little and paste it to pastebin:
(erased the : between https and // because i still cant post links and the hint with ’ wont work
Maybe you can see in the log what happen…

[fixed url and updated settings to allow links - mod]

Ext. 25 is doing some complex stuff with ICE that I’m guessing Asterisk is not handling correctly. Possibly, turning that off will help.

However, let’s try something even simpler: call *43 (echo test) from ext. 25 (the Snom). Does it connect? Do you hear the instructions? Do you hear the echo?

If that works ok, we’ll try something more complex, perhaps with simpler settings in your app or a different softphone. If it fails, paste the log of it and if needed we’ll look at a packet capture.

25 is the Softphone, 20 the SNOM.
Tried your hint with *43…
*43 from the softphone works fine and i hear the voice and also the echo. So i tried once more a external call and this time it also works fine an i hear everything. Maybe when i tried to call external yesterday, the ip settings wasnt correct and this would be the reason while there was no audio.
Internal call from the softphone to 20, the SNOM rings but i get no audo.
*43 from the Snom, the display shows “connected”, but no audio.
External call from the Snom also gets an connection but no audio.
Internal call from the snom to 25 ends immediately and the display shows “service unavailable”.

Since now i also thought that inbound calls wont work because the Snom doesnt response on incomming calls. But now i changed the inbound rout from 20 to 25 und now the softphone rings on incomming calls.

So there must be something strange with the extension 20 inside the freepbx ore the failure is inside the snom.

I know nothing about Snom, but does it seem that audio is otherwise working ok? For example, do you hear a dial tone? Can you connect directly to a SIP provider? If no sound at all, check that it’s not something silly like connecting the handset to the headset jack, or try a factory reset and configuring again.

You might run sngrep and call *43 from the Snom to see whether RTP packets are flowing in both directions to the correct IP addresses and ports. If so, try capturing traffic with tcpdump and examining it with Wireshark. Is the RTP from the Snom technically ok (correct codec, packetization, etc.)? If so, try playing it to hear whether your voice is actually present.

Sry for my late reply. This silly failure was exactly the Problem with the snom Phone. I bought this phone months ago and did not check if the handset is connected to the right jack. And as this is not enough silly failure, i connected the lan-cable to the pc-out which works like a switch to connect a pc or something else. Interestingly this works for external outbound calls, internal inbound calls and to configure the phone via webinterface, but not for outgoing calls to an internal extension. After connecting all cables right, the phone works well, and the freepx also.

Thank you very much, Stewart1, for your friendly and helpful replys.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.