New Distro installation not installing Freepbx

I picked up a demo FreePBX box when I was in Naples for training a little over a year ago. I wanted to load up the new 12 version on the box and I’ve tried about 12 times now with RAID, no raid, 32bit/64bit, USB install via the ISO and IMG with the same results. It’s like nothing actually gets installed.

When I log in the first time I don’t get the normal start-up screen, wget isn’t installed, and there are no yum repositories configured properly. I did notice one strange thing during the install (not sure if this is new to 12). It asks me what type of role do I want with PBX, recomendation is minimum, but there are also desktop, web server, database, and a few other options. The first time I selected desktop, but the subsequent installs I chose minimum.

I mention it because there seemed to be something similar in the forums --> Freepbx Distro Doesn't Install Freepbx or Asterisk

Ok, so after digging around other’s people issues I’m 99% certain it is because I’m using the ISO image on the USB drive. I’ve attempted to load the IMG image using 4 different programs, but all I get is “boot error” in the top of the screen. The ISO images at least let me get the installer running initially, but it apparently never references the asterisk installer (can’t find kickstarter), so it just gives me a base CentOS. I did come across someone’s blog about their fix, but I have reached my level of incompetence, and am unable to get his instructions to work for me. Here’s the link to a possible fix for someone else -->

I presently don’t have a USB CD-Rom, so I guess I’ll be picking up a cheap IDE to USB to see if I can get a standard DVD to work for me since I can’t get the thumb drive to install FreePBX properly. Frustrating to spend more than 4 nights after work just to install an OS for dummies. Hopefully the Jury-Rigged CD-Rom will solve all my issues.

from any linux box even the half-assed one you built :wink:

dd if=FreePBX-64bit-10.13.66.img of=/dev/sdx bs=1M;sync;reboot

where sdx is your previously mounted usb device, perhaps identified with

cat /proc/partitions |grep -vE [0-9]$

Thank you for the reply. I wanted to exhaust all the options before I replied. I didn’t have a linux box at the house, so I mounted the Freepbx ISO into a VM, got it up an running and then mounted the USB to run the dd command you supplied. I still got boot errors, so I brought the machine into my office and used our production PBX to run your commands (minus the ;reboot) and I got further. I get Syslinux 4.02… on the top of my screen, followed by “No DEFAULT or UI configuration directive found!” I threw the USB back into my windows box and re-ran W32DiskImager and tried to boot the machine again with the same results, stuck at a “boot:” prompt.

This IMG isn’t apparently going to cooperate with me on any operating system. I’m just going to have to leave the second drive disconnected and install it off of a SATA DVD drive, and forget about having a RAID set. Thank you again for your advice dicko.

Sounds like an efi boot problem. Disable it in the bios if possible.

No joy. Just disabled the UEFI boot and I’m getting the same message. I’m going to see if there is a BIOS update, but don’t think it will help.

2nd hard drive removed. DVD install worked like a champ on the single drive. Thank you for trying dicko, but I’ve already spent too much time just getting started.