New distro install digium phone tool not working

Have had an AsteriskNOW system up and running for a few weeks and decided to try the FreePBX distro.

FreePBX Stable-4.211.64-6
64bit 08/14/13
Asterisk 11

got it up and running no problem but it seems a little flaky with the digium phones app.

specifically, when I try to move a logo over to a phone from the available logos, it moves over but after I save and apply, the logo isn’t in the assigned logos, it’s back in the available ones…

is this a known bug or am I doing something wrong?

this worked fine in the AsteriskNOW 3.0.0 version of FreePBX.


I seems there are a whole slew of settings that wont save. Tried this in firefox and MSIE, the behavior is the same in both.

under digium phones > general settings, if I try to change the “phone authentication method” it bounces back to “mac address” after a slave and apply…

I’ve bounced the entire system… still no improvement…
doing a “yum update” and see what that gets me…

well, after issuing a yum update on the system, the FreePBX seems totally broken now…

php permission errors galore…

[Thu Sep 12 20:49:44 2013] [error] [client] PHP Warning: session_start(): open(/var/lib/php/session/sess_kp0kks2an4hbqjjks3lh4mcss3, O_RDWR) failed: Permission denied (13) in /var/www/html/admin/config.php on line 78, referer:

anyone know what’s going on with this? Did I do something wrong by doing the yum update?

and apparently the digium phone issue is a known one…

Maybe (should I say “Yes”).

FreePBX Distro should not (better: MUST NOT) be updated directly through the yum command as happens when you manage updates/upgrades in a “common” Linux distribution supporting yum based update tool (like CentOS, Scientific Linux and RedHat, just to make some examples).

To update (and upgrade between major branches, as example, between 3.211 and 4.211) FreePBX Distro you need to deploy official Scripts available here.

If your FreePBX Distro is 4.211.64-6 means, now, that it’s the latest (-6) available and when (-7) become available you could update it through the appropriate update script.

At higher level (FreePBX) you can manage various FreePBX modules through FreePBX web management interface (GUI) by means of Module Admin which let you look for (modules) updates.

You could do that also via CLI but GUI is nice and responsive too.

Many other information are on the Wiki.

<a href=>Here you can find FreePBX tickets about Digium. Stay up to date with Digium module and read here too.

If you like to manage modules update through CLI (I find this a nice way to deploy updates through a SSH connection) an interesting reading it this page (I have to check if it’s still necessary to perform an “amportal a r” to mime the “Apply Config” button selection at the end of a update or if this part is contained into “amportal a ma” command).

By the way it’s quite straightforward.

OOps you don’t appear to have FreePBX Distro but only FreePBX…I misunderstood (basically some things I wrote are still valid).

Yes actually it is the latest distro downloaded from FreePBX.

Thanks for the info!!

Yep, I misunderstood because first I tough I read only FreePBX on your posts so I commented myself but finally I’ve read your post once again to discover you mean FreePBX Distro really.

IMHO FreePBX Distro is very ease to manage (as Linux administrator I mean), it just have some particularities because is made over CentOS but behaves like a true specific appliance’s distribution.


The ticket for this issue has been closed, and the update pushed in module admin version of the Digium Phone Module,

Please report any additional issues or bugs at