Networking issues

So I have a very perplexing issue here…

I set the Static IP during install which went fine and even passed the internet check. But after the first boot following the installation it refuses to connect to the network.

  • I have double checked the /etc/sysconfig/network-scripts/ifcfg-eth0 all settings are correct.

  • I cannot ping google.com or 8.8.8.8

  • Gateway Ethernet Ports are lit as well as the NIC lights.

  • All software installed correctly and nothing has changed between the time of install last night and now.

  • Pulled hard drive from server and threw a working hard drive that was previously in there with a LAMP stack and it works beautifully assigned to the same Static IP. Debian Wheezy Distro

  • All Static IP info is a match for provider information and is the same as the rest of the Statics I have assigned to me.

  • Ran a temp Ethernet Cable from Gateway to Server and that was a no go too.

“STABLE – 10.13.66” downloaded yesterday from the FreePBX Distro Download Links" page http://downloads.freepbxdistro.org/ISO/FreePBX-64bit-10.13.66.img being the exact image I downloaded.

SuperMicro Server Quad Core 2.9ghz 8gb Ram and a Brand New Seagate Constellation 1TB Data Center Class HD

Hello,

You mentioned that the ifcfg-eth0 settings are correct. Let’s start there.

Please boot up your FreePBX box, and login to the text based console. You might see an ASCII art text box with your interface, MAC addresses, and IP information.

This is what mine looks like:

Current Network Configuration
+-----------+-------------------+--------------------------+
| Interface | MAC Address       | IP Addresses             |
+-----------+-------------------+--------------------------+
| eth0      | 00:90:27:ED:69:2A | 192.168.1.50             |
|           |                   | fe80::290:27ff:feed:692a |
| eth1      | 00:90:27:ED:69:2B |                          |
| eth2      | 00:90:27:ED:69:2C |                          |
+-----------+-------------------+--------------------------+

You should then type in

route -n

and get an answer similar to:

[email protected] ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0

Note the entry of 0.0.0.0 as this is your default gateway, in my case 192.168.1.1

Try to ping your default gateway. Also try to ping another machine on that subnet. In my case, I would try 192.168.1.1 and another device, such as a phone, at 192.168.1.200 and your setup will certainly be different.

Note that your router can have a firewall that declines pings, therefore having another device on the same subnet is handy for testing.

My gut guess is that you have:
– No default gateway defined
– Bad subnet mask
– IP conflict

You can also go to your router, and see if the router sees (pings) your FreePBX machine.

If you want to get really fancy, you can try tcpdump in a second session, and perform a packet sniff, or you can put a hub (or a port mirror on a switch) and use something like wireshark to see what the network is doing.

Christian

1 Like

In addition to @cyberdocwi’s awesome debugging instructions, I would also check that the network interface you THINK is eth0 is actually eth0.

Try using the command ‘mii-tool eth0’ and making sure it is actually reporting up and connected when you’re expecting it to be.

You may need to move a network cable to a different port.

OK a little more about my setup. I had Comcast Business come in and install internet here just a few days ago now. I have one device plugged into the gateway, a windows PC. Eventually there will be a few more but at the moment I only want that gateway (cable modem) providing service to dedicated hardware. I purchased a block of 5 usable static IP’s this in all reality gives me 6 IP’s to use. The sixth being assigned to the gateway and that gateway providing DHCP to a LAN. So my Windows PC has an internal IP range address. Now I have verified that the Static IP’s do work by requesting a proper IP from the gateway using the IPv4 properties in windows. I had another hard drive with a LAMP stack running Debian that is able to use all the IP’s.

I do not want to post my external facing IP’s in open forum. This would be a recipe for disaster! I am quite certain that I will get plenty of attempts at my setup regardless of what I do but hey why make it worse :wink:

ping google.com > unknown host google.com

ping 96.xx.xxx.xx > (my gateway address) Destination Host Unreachable (Works from Windows Computer)

mii-tool eth0 > eth0: negotiated 100baseTx-FD flow-control, link on

I redirected the output of the route -n to a txt file and moved it to a usb for this one.
Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface xx.xx.xxx.80 0.0.0.0 255.255.255.248 U 0 0 0 eth0 169.254.0.0 0.0.0.0 255.255.0.0 U 1002 0 0 eth0 0.0.0.0 xx.xx.xxx.86 0.0.0.0 UG 0 0 0 eth0

So if you will notice the first entry in that output shows the last octet as .80 I do not know where that is coming from that is nothing I have programmed in any of my config files. The last entry for the Gateway is correct and coincides with what was provided by Comcast. I assume its like your last octet of .0

I am all ears and willing to do just about anything. If you need a non redacted copy of an output I can send via PM

Forgot the ping from Gateway to FreePBX box…

Pinging xxx.xxx.xxx.xxx:
Request timed out.
Request timed out.
Request timed out.

Ping statistics:
Pings sent: 3 (0 per second); Replies received: 0 (0 per second)
Bytes sent: 192 (48 per second); Bytes received: 0 (0 per second)
0 replies passed verification (0 failed)
Min time: 0 ms; Max time: 0 ms; Avg time: 0 ms; Total time: 4994 ms

BTW I am literally assigning an external facing IP to my FreePBX box in an identical setup to what I have being hosted on a VPS currently.

Hello Chad,

Sorry I did not see your responses until recently. Thank you for sending the information. You appear to have a Class A network allowing 6 hosts per subnet. My gut guess for this conversation is that your valid range is 96.x.y.80 through 96.x.y.87 as your linux box is reporting a .248 subnet mask in the routing table.

In that case, .80 is your subnet ID, like .0 would be in the classic 255.255.255.0 scheme. .87 would be your broadcast address, like .255 would be in the classic 255.255.255.0 scheme. .80 and 87 may not be used at the workstation level, as they are “bookends” to your subnet.

.80 is your subnet ID.
.86 is likely your router / gateway IP to Comcast

I wonder what your FreePBX IP address is. If left to default DHCP, if your Comcast device is not issuing IP numbers (not running DHCP) then you don’t have a firm IP address to work with. If you programmed a static IP, did you remember to use the same subnet mask 255.255.255.248 as required by your network?

Check your FreePBX server’s IP address, and make sure it has the right subnet mask.

IF that matches up, I would then start turning off firewalls. Can the Windows box ping the FreePBX box? Once connectivity is established, restore the firewalls, and see what breaks.

I will be back “at work” on Monday, and if you wanted to do a Private Message thing, I am interested in helping. Others helped me on this network, and I can give back.

Christian

You are correct! And the Comcast Business Class Modem is a simple switch/firewall/router/modem device absolutely dreadfully void of any features that would be needed.

So I paid for 5 usable statics which are .81-.85 and .86 is assigned to the modem which is used for the router. By default anything assigned a static is not firewalled at all. Also by default if you don’t assign a static in the device then the dhcp server built into the all in one “Business Gateway” then you get a 10.1.10.xxx address and that is using the .86 ip address

For example I have a web server setup on one of them a Debian on the exact same hardware specs as the freepbx (got a good deal on three full server setups). I have it already mounted in my open frame rack. I had no trouble whatsoever assigning a static to the Debian box. Enter the static details into the /etc/network/interfaces commenting out dhcp lines and replacing them with the static details and poof it all works beautifully. On my windows boxes I have tested out having a static although I don’t need it so I let the router in the box handle my workstation. I even tried a live version of centos just to see what would happen booted my server box from the live distro i dumped on a USB drive and it would not connect. But a Debian distro I have on another hard drive worked just peachy.

Hello Chad,

Comcast and their friends (Time Warner, Big Box DSL) seem to provide dumb/stupid devices to the end users (us) to simplify configuration for the masses. Thus, anytime I have a business connection that I consult for, I push the business to get a proper firewall/router setup, and simply have the ISP push their box into a bridge, and let me control all of the settings on the proper firewall/router setup.

Common devices I use are older Linux boxes with 2 network cards, or Mikrotik devices. I like the Mikrotik components for cost and configuration simplicity, but Mikrotik doesn’t support UDP OpenVPN, so if I want to do fancy VPN work, I plop a computer down.

Anyways, FreePBX is using CentOS 6.x, which is a re-branded RedHat Enterprise Linux 6. Do not search for RedHat 6, or you may confuse with results from the RedHat “Original Series” of which RedHat 6 was around the turn of the century, 1999-2000.

As I do not like major servers to sit outside of the firewall, may I suggest the following:

– Put a Router in front of the FreePBX machine
– Configure the Router to forward ports if required
– Have the FreePBX machine on the local network

If you want to get into the guts of CentOS networking, you can find the configuration scripts in /etc/sysconfig/network-scripts and the ifcfg-eth0 is the first network card. Warning that you should not hand-modify those files, as if they are out-of-sync with the web interface, you could start chasing your tail again.

If that fails, I think it may be time to re-install FreePBX.

Christian

@cyberdocwi

I have to say that I had planned to wipe and reload anyway. I was just hoping to get it to work first so I would have it narrowed down and could better handle any issues that may arise in the next load.

I have been looking at taking one of my little rack mountable servers and turning it into a Firewall/Router using Untangle. It seems quite powerful for the average home user like myself. Has all the features I would ever need in the base free distro and is simple to use. I am just learning and sometimes I have to ask very dumb questions in forums like these just to get by. I have to say if it as not for patient forum members I would never have learned anything about Linux, FreePBX, etc. I will perform the reload tonight and hope it all goes well. I will just set it to DHCP to start with and see where we go from there. If I can get to the Web UI from there I will try it that way then make changes using the FreePBX front end. Wish me luck!!

Complete wipe and reload…

Used an internal IP range for Static configuration 10.1.10.2:

Testing for internet access
Some firstboot error occured, and the system is not properly setup.
Check to see if you have internet access and re-run /etc/pbx_first_boot.sh
Press ctrl-alt-f1 to continue

I will try a second time to wipe and reload and this time I will use DHCP just for gits and shiggles. Again no ping to either google, gateway IP or google IP

Apparently it does not like me!!!


4th times a charm??? (Total number of times over the past week and a half!)

Testing for internet access
Internet Access Test Passed

Updating all FreePBX modules. This can take 5-10 minutes. (11:45pm)

Enabling FreePBX Commercial modules. This can take 5-10 minutes. (11:54pm)
12:16am and it is still sitting there doing what appears to be nothing!!

Restart asterisk bla bla bla… (12:21am)

WTH - I cannot ping google.com, gateway or google IP’s again. This is ridiculous to say the least, why the heck does a simple Debian distro work flawlessly and FreePBX will not??? I am at a total loss here!!


So my “Current Network Coinfiguration” screen that shows up when you first login to the CLI shows valid and information. It says I have an IP of 10.1.10.13 on eth0 and an IPv6 entry. But nothing for eth1 which is the way it should be since I have nothing plugged into eth1.

My route -n show a nearly identical match to @cyberdocwi 's previous post replacing my IP’s. I still have no network access at all. I am going to hit the hay for tonight but there is some food for thought for you all. I would have thought it was a MAC filter in place by now or something but again as previously said a few times I have tried a Debian distro on the same box and it works so I know it is not internal to me it has to be something in the FreePBX Distro.

Just to be sure that I didnt have a hardware issue I decided to wipe out FreePBX and install Debian 8 Jessie via netinstall flash drive. I installed it to the primary hard drive (all these wipes and reloads are gonna kill my brand new drive, lol) so I did that last night before bed I wrote a shell script that ping’d google.com, 10.1.10.1 and 8.8.8.8 every 30 minutes it sent one ping each of the three destinations and appended the results to a text file. The text file looks great all pings successful. Continuous operation for nearly 12 hours with no drop in connectivity.

OK so here we go with another couple trys at this…

I have reloaded FreePBX back on to the server. I brought the server over to a family members house to do this. I had it connected to a standard residential grade Comcast account. At this location I have a simple cable modem only (permanently bridged to its only Ethernet) and it is connected to an Asus RT-N66U router. The first wipe and reload was strictly DHCP settings and it did the same as the last failed install I noted above. The second full wipe and reload was a total disaster too, this time I assigned a static IP 192.168.1.210/255.255.255.0 and 192.168.1.1 as well 8.8.8.8 as DNS servers. Now I have installed Linux based setups so many times I cannot even count them all. This is the worst time I have ever had installing a distribution in my whole life. I have built ham radio voip interfaces using IRLP which runs strictly on Linux (for several years that was CentOS based), I have 3 Raspberry Pi’s that all run Linux and I have web servers and VPS accounts that all run Linux. My point is that I am no stranger to Linux (NOT an expert either!) but I am getting my butt handed to me by a FreePBX distribution. I cannot imagine it but is it possible that there is a driver issue with a SuperMicro board and CentOS this seems pretty far fetched since the SuperMicro is server grade equipment, but I have exhausted all other alternatives and I am now completely and totally at my wits end. I just simply cannot afford an appliance if all this fails I may repurpose the SuperMicro and try out a different rack mount server for the FreePBX, but things are getting expensive here for me. thank you for any advise and tips you may have.

A post was split to a new topic: Network Issues

Thanks - So simple but caused me 2 hours of searching and running commands I’ve never heard of. This one did the trick.