Netinstall issue with NIC - half solved

Hi, I am trying to install the distro.
My Linux knowledge is limited.

I saw references to but no solution to my issue on the forum.

Once I got the Kickstart error, I realised that my NIC was not working as I have an Asus P5G41T-M LX motherboard with an Atheros 8131 NIC, not supported in CentOS 5.7 (appears to be supported in CentOS 6).

So, I installed CentOS 5.7 Final from and got the NIC working with a driver from - so far so good.

I now have the appropriate atl1e.ko file (the kernels on the freepbx and centos distros appear to be the same 2.6.18-274) and have it on a USB flash drive.

The plan was to go through the freepbx distro installation process manually and when set to http, it asks for an appropriate driver for the NIC.
This is where it all falls down. I pointed the installer to the .ko file, no joy.
Then I tried to create .iso and .img files, no joy. I presume the .ko file is somehow supposed to be integrated into the .img file.
I’m sure I’m just not creating the .img file the right way that the distro expects but I can’t find any decent how to’s or I am not searching the right way.

Can anyone point me in the right direction, I feel like I’ve read half the internet, the wrong half obviously ? Thanks, much appreciated.

Does anyone have a solution for this, would appreciate greatly. Thanks.

You could install a additional NIC that is supported.