Needing help setting correct trunks in freepbx13

Hello Guys
I have setup an box with freepbx13 and I needing help setting up correct trunks from my provider which is VoIP Innovations and they dont use username or secret to authentication but do use IP Address for authentication. From there page I have to setup 2 different trunks for in and out when I tried to do this I get this number not in service or cant dial out from remote phone/extension. So I contacted them they told me I was sending 404 to them and I need to put context=from-trunk to make it work and I have tried that and still dont work. Also this box is behind an miktroik routerboard which does have port 5060 open.

Please refer this link : and post the Asterisk CLI logo here.

I use an IP verified trunk.

In the incoming settings I have:

Then in the asterisk SIP Settings, under External address, I have the address the provider is expecting.

that didnt work so I need some more on this. I have 2 working extension that can call each other just fine but I cant call in lets say from my cell phone to that number or I cant call out from one of the extension.

I’ve been working with VI for years.

You can’t use PJ-SIP because VI uses host-based authentication. Set up your trunks with Chan-SIP, and go to the Wiki. They have a page on setting up FreePBX. If you are still having problems, send me your config and I’ll correct it and send it back to you.

I’d send you mine, but I can’t access my home PBX trunk page from my work, so I’d end up retyping the whole thing for you.