Need help with the Grandstream GXW-4108 FXO gateway

Hello I bought a Grandstream GXW-4108 FXO gateway 8 Channel I searched online to many websites and pretty much got lost. But i did mange to find this site Install guide for the GXW-4104 that is for the 4 channel fxo gateway i did follow it but some odd reason i can not get my Freepbx server to see it. below is the settings on my freepbx sip trunk.

Trunk name: GXWT1
outbound caller id Empty box
CID option: Allow any CID
Max channels 8
i have nothing set on the Dialed Number Manipulation Rules
Trunk Name not sure if that is the account name from the grandstream box or the user account from the grandstream.

PEER Details

user content box is empty
So is the user details box empty.

Register String box is empty.

Can someone please help me out? I’m not sure what I’m doing wrong. i really need help

If i put a Register String in there GXWT1:[email protected]; i get this from putty

[2016-08-19 14:23:25] NOTICE[2592]: chan_sip.c:15227 sip_reg_timeout: – Registration for ‘[email protected]’ timed out, trying again (Attempt #1)

can you look at any logs on the gateway? you should be able to see the pbx attempting to register the trunk with the gateway

I used to have a GXW-4104 working correctly with FreePBX.

These posts might be helpful for you, I used them to configure mine:

helllo bksales where can i find the logs at for the fxo gateway. This interface is way different from all the other sites i have seen. I’m guessing because of the same firmware.

Hello Arielgrin i tried that site and same thing I do not know what I’m doing wrong. I even found that post as well and tried to follow it.

unfortunately i don’t have access to the gateway so i don’t know what logging capabilities it has. if you can’t figure that out, then i would do a tcpdump on the NIC that this is connected to and look at the output in wireshark. at least you will be able to see what is coming and going.

by the way are you using the freepbx firewall? i guess i also never asked if this is a freepbx distro or you rolled your own

I could try to help you, if you feel comfortable by letting me connect to your teamviewer session. Just let me know and I will try to help you. It would be helpful if you open a TXT file on the PC that is running teamviewer with the IP of freepbx and the IP of the gateway, along with the usernames and passwords.

Not sure if this forum will let you send a private message directly to me with the ID and password for the teamviewer session.

sure i can give you access id is 420 140 924 password is 8243

Are your inbound and outbound routes working? I have 4104 gateway and I can’t make outgoing calls.

From what I’m seeing the dial plan has to be set for that. arielgrin helped me with mine.

Where is your dial plan configured? Can you post it here?

There are a number of problems with your message.

First, you haven’t really told us what is not working. You simply say that you cannot get your FreePBX server to “see it.” What does that mean? Does that mean you cannot place calls out? You cannot receive calls in? Or perhaps that you’re not seeing the Grandstream box in the Asterisk Info module?

Second, your configuration is wrong.

Under ->

Outgoing Settings:
Trunk Name: GXWT1

NOTE: The trunk name above must match the username set in the channels tab of the GXW-4101, or calls that come in on the phone lines attached to the GXW-410x will not be accepted by Asterisk!

Third, your PEER Details have other errors. Please see:

Fourth, Please provide more information:
A. What is the IP address of your PBX?
B. What is the IP address of your Grandstream box?
C. In the Asterisk Info module, under Peers, what does it say regarding GXWx?? do you see anything like this:

GXWT1 N 5060 OK (3 ms)
GXWT2 N 5062 OK (2 ms)

Fifth, you definitely do not want a registration string in this case. I don’t think that the GXW can accept a registration from another device, and if Asterisk cannot register, it may mark the trunk as down.

Sixth, you really just need to follow the guide. I wrote it, and it still works - though the various options are in slightly different places now, they’re all named the same or close enough.

Here’s another guide, from Grandstream, that I used when setting up my configuration:

Hello i have the problem with the grandstream box again. Well i thought it was a network problem but what turned out to be a network wire problem. So my stupid self reset the grandstream box. I did manage to somewhat reprogram it. I can get incoming calls. But not outgoing calls. I’m not sure what to do i really need help. I don’t know what to post in here to give the information on what is going on.

Edit. Now I’m thinking about it. The grandstream box is working. What is not working is the outbound calling. It is strange because it was working before all this happen.

Let me know if you would like my help just like the last time.

I think the grand stream box is working because I’m able to receive calls. Just not able to make calls. It says all lines are busy But i know for a fact that they are not in use.

I have changed nothing on the Pbx side that all remain the same. So i looked at the 8 Port grand that i have learned from it and in order to program the 4 port fxo box. I’m not sure what is going on.

Hello this is just a update When i try to call out i get this in the

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/GXW4104/6097751699
– SIP/GXW4104-000002b2 is ringing
– SIP/GXW4104-000002b2 answered SIP/835-000002b1
[2018-10-11 15:34:26] NOTICE[8162][C-00000063]: res_rtp_asterisk.c:4444 ast_rtp_read: Unknown RTP codec 95 received from ‘’
– Executing [h@macro-dialout-trunk:1] Macro(“SIP/835-000002b1”, “hangupcall,”) in new stack
– Executing [s@macro-hangupcall:1] ExecIf(“SIP/835-000002b1”, “0?Set(CDR(recordingfile)=.wav)”) in new stack
– Executing [s@macro-hangupcall:2] GotoIf(“SIP/835-000002b1”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [s@macro-hangupcall:4] Hangup(“SIP/835-000002b1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/835-000002b1’ in macro ‘hangupcall’
== Spawn extension (macro-dialout-trunk, h, 1) exited non-zero on ‘SIP/835-000002b1’
== Spawn extension (macro-dialout-trunk, s, 22) exited non-zero on ‘SIP/835-000002b1’ in macro ‘dialout-trunk’
== Spawn extension (from-internal, 6097751699, 7) exited non-zero on ‘SIP/835-000002b1’

I’m not able to call out. I didn’t change the dialing pattern or nothing it’s been running for a full year no problem. Incoming calls are good no problems there it’s outbound I’m not able to call out.
I’m using a Grandstream box 4FXO channels.

Can someone please help me.

All guides became so out dated. Any chance to have a new version compatible with FreePBX 16 somewhere?. It’s my 3rd day now trying just to configure my GXW4108 :frowning:

What is going wrong? If using registration, does it register ok? What happens on incoming? On outgoing?