Need help with multiple devices on same extension

Hello everyone!
There are already a lot of other tread with the same question, but i’m too inexpert to figure out the real way to achieve this: having a desk phone registered to one extension and add a softphone to the same extension!

I just need that they works one or the other! I mean that the softphone must allow a user to launch calls from outlook and websites (i already managed to use a “click-to-dial” addon, but it works only for my extension wich is registered only to a softphone), while the desk phone must be able to make and receive calls as it is already doing

I read about using PJSIP “contacts” feature, but i’m stuck on classic SIP so i cant use this function, and i read about “Device & User Mode” but the dislaimer on the wiki make me feel i’m going to only damage my system by playng with this mode…

any advices?

Yes, you convert your extensions to PJSIP. That solves the issue right away.

Why are you stuck? Any supported version of FreePBX (13+) can do pjsip.

I’m aware of this because in one of my first post you told me about this…
I dont know if you remember, but you are one of the guys who helped me figuring out some stuffs while configuring FreePBX to a gateway using sip because i was too noob to make PJSIP works!

So, i’m too scared to try out pjsip, expecially because if i start to testing stuffs and they doesnt work, my company telephone system will be cutt-off! (my whole system at the moment works really good! managed to add an IVR, using ring groups, queues and other stuffs like that)


PJSIP and SIP can be used in conjunction. You can keep your trunks and existing extensions as CHAN_SIP. Your multi-station extensions can be PJSIP.

1 Like

I know, one of the things i had to do, in order to make my systems works, was to enabling both chan_sip and pjsip (even if all my extension are sip)

I’m already testing this path, thanks for your tips anyway! ^^

edit: since you seems to have a good knowladge, may i ask wich port i should set pjsip?
i mean, my sip is on 5060, pjsip is on 5061!

I think everything is using port 5060 (starting from the gateway wich is my trunk)

This is in no way mandatory, just a convention on default installations.

If CHAN_SIP is running on 5060, you probably want to run PJSIP on 5160, so you have 5061 for Secure CHAN_SIP and 5161 for Secure PJSIP.

This way, your port assigment would correspond to the documentation, at least in regards to legacy configuration of the distro.

Current distro sets PJSIP to 5060 and CHAN_SIP to 5160.

Okey, i’ll try it this way, thanks!!

Just fui, you can have a ChanSIP trunk on 5060 and a PJSIP extension on 5061 and vice versa.

1 Like

Hey guys, i’m sorry but i’m missing the point…

I create an extension pjsip, i then try to use its credential but it wont connect! the most strange thing is that the log files says “wrong password” but i just copy-paste that “12345” (also tried manually, without copy-paste)

There is another question further this problem…
In the “contact” config, you can chose only sangoma/digium phones… so, assuming it can connect to the server, i dont see how i would be able to set up this extension on a softphone (Xlite) and a deskphone (Yealink)

edit: i founded in the logs some lines with the following error:
“[2018-12-11 09:59:56] ERROR[1958][C-0000021a] res_pjsip_header_funcs.c: This function requires a PJSIP channel.”
it seems that pjsip is disabled… but its enabled :confused:

From your screen cap we can see the pjsip extension is listening on port 5100, but you haven’t configured your soft phone with the port. Try setting the domain to

1 Like

ooooh my god, thats the trick! i’m so thankful for your help!
I had no idea it was such an easy thing…

i will now try to set it on the deskphone (i assume its kinda the same thing)

thanks again for the help!!!

1 Like

it does works … except that FOP2 got reeeeally f.up :open_mouth: :confused:

i’m trying to do a reboot (asap everyone in the office end theyr calls) and see if it start working properly… i hope so!!

UPDATE: fop2 is now fine after a reboot, but i’m scared to do this again…
Do you have any knowledge on how using 2 device on one pjsip extension and fop2 interact?
i’m worried that having multiple device on one extension just broke the panel…

PJSIP extensions work fine on FOP2 as long as you set it up manually. FOP2 currently has no concepts for “auto generating” PJSIP extensions as it doesn’t have anything in the code to look for them.

if you are talking about writing code, then i think i’m unable to reach my onjectives…
if you are talking about using the fop2 admin panel gui, then maybe i can do it :stuck_out_tongue:

FOP2 requires that the “buttons” you see are configured, it uses the config file for this and when you use the “FreePBX” stuff on it, it generates that config “automagically” for you. Since it’s pulling from the DB and doesn’t know what to do with PJSIP tech extensions, it doesn’t create buttons.

So it’s as I feared, i need to write in the config file!
Well, thanks for your tips & tricks, but i cant go further, i have a reeeeally low knowledge for this…
thanks anyway,

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.