Need help! Problem setting DIDs for ZAP Trunks

I have set DID numbers to all of my ZAP trunks and set inbound routes to use those DIDs but still no hope. The DID keeps getting set to “s” and going to default ring group. What am I doing wrong. I am kind of new at this.

Here is the info I got from the “asterisk -rv” command.

-- Starting simple switch on 'Zap/4-1'
-- Executing [[email protected]:1] NoOp("Zap/4-1", "Entering from-zaptel with DID == ") in new stack
-- Executing [[email protected]:2] Ringing("Zap/4-1", "") in new stack
-- Executing [[email protected]:3] Set("Zap/4-1", "DID=s") in new stack
-- Executing [[email protected]:4] NoOp("Zap/4-1", "DID is now s") in new stack
-- Executing [[email protected]:5] GotoIf("Zap/4-1", "1?zapok:notzap") in new stack
-- Goto (from-zaptel,s,8)
-- Executing [[email protected]:8] NoOp("Zap/4-1", "Is a Zaptel Channel") in new stack
-- Executing [[email protected]:9] Set("Zap/4-1", "CHAN=4-1") in new stack
-- Executing [[email protected]:10] Set("Zap/4-1", "CHAN=4") in new stack
-- Executing [[email protected]:11] Macro("Zap/4-1", "from-zaptel-4|s|1") in new stack
-- Executing [[email protected]:1] NoOp("Zap/4-1", "Entering macro-from-zaptel-4 with DID = s and setting to: 6238471290") in new stack
-- Executing [[email protected]:2] Set("Zap/4-1", "__FROM_DID=6238471290") in new stack
-- Executing [[email protected]:3] Goto("Zap/4-1", "from-trunk|6238471290|1") in new stack
-- Goto (from-trunk,6238471290,1)

== Channel ‘Zap/4-1’ jumping out of macro ‘from-zaptel-4’
– Hungup ‘Zap/4-1’
– Starting simple switch on ‘Zap/4-1’
– Executing [[email protected]:1] NoOp(“Zap/4-1”, "Entering from-zaptel with DID == ") in new stack
– Executing [[email protected]:2] Ringing(“Zap/4-1”, “”) in new stack
– Executing [[email protected]:3] Set(“Zap/4-1”, “DID=s”) in new stack
– Executing [[email protected]:4] NoOp(“Zap/4-1”, “DID is now s”) in new stack
– Executing [[email protected]:5] GotoIf(“Zap/4-1”, “1?zapok:notzap”) in new stack
– Goto (from-zaptel,s,8)
– Executing [[email protected]:8] NoOp(“Zap/4-1”, “Is a Zaptel Channel”) in new stack
– Executing [[email protected]:9] Set(“Zap/4-1”, “CHAN=4-1”) in new stack
– Executing [[email protected]:10] Set(“Zap/4-1”, “CHAN=4”) in new stack
– Executing [[email protected]:11] Macro(“Zap/4-1”, “from-zaptel-4|s|1”) in new stack
– Executing [[email protected]:1] NoOp(“Zap/4-1”, “Entering macro-from-zaptel-4 with DID = s and setting to: 6238471290”) in new stack
– Executing [[email protected]:2] Set(“Zap/4-1”, “__FROM_DID=6238471290”) in new stack
– Executing [[email protected]:3] Goto(“Zap/4-1”, “from-trunk|6238471290|1”) in new stack
– Goto (from-trunk,6238471290,1)
== Channel ‘Zap/4-1’ jumping out of macro ‘from-zaptel-4’
– Hungup ‘Zap/4-1’

Right now I have deleted the “s” inbound route so the calls are going nowhere.

Well,

Don’t know what your Inbound Routes look Like, But you are making it through the “from-zaptel” context and setting the psudeo DID properly to 6238471290. Also, don’t know what you mean by deleted the s route. s is not a route, but the “Start” indicator for a dial plan or dial plan context. I would check the context “from-trunk” and see what happens when you match to this psudeo incoming number …

I am also new to this but through research I was able to get Zap DID working. What you need is an additional component in FreePbx called “ZAP Channel DIDs”.