Need help Changing packet size to 30ms

I’m currently running Cisco 7940s. They are running at 20ms and I want to change that to 30ms. I am using g729 as my codec. For some reason i can’t get them to send and receive at 30ms. Please help.

I’m not familiar with that phone, but if you have ulaw or alaw enabled (g721u/g721a) enabled, even as not the “preferred” codec, it may keep you from using 30ms because 30ms isn’t a valid setting for use with those codecs (if you get a phone that allows it, it will cause clicks/pops/noise). I don’t know if 30ms is allowable with g729 or not, but even if it is, if use of one of the other codecs could be forced by the other end, they might not permit you to set 30ms. Just a thought.

You have to set them to nat=no and qualify=no for them to work.

What other setting do i have to set to get this to work? I set them to nat=no and qualify=no but they still send at 20ms.