Need a New QUEUE added but can't get it to work!

I am new to FreePBX and understand the basics of the system. It was already in use before I started where I work. But the architect of the system is long gone now and some of the staff are asking for another queue to be added to the system. I have copied everything I can think of from all of the other queues but nothing shows up on our Polycom IP550 under a Tester extension I set up. is there a common mistake I might be making that other people have made by just coping all the settings from the other queues? Thanks for any info anyone can provide!!

Hi Quintis,

I don’t have any queue experience but in general, the following things are extremely helpful:

  1. Version Numbers (Asterisk, FreePBX, Module, OS)
  2. Screenshot(s) of settings page(s)
  3. Step-by-step description of how you’re implementing the process (for example, if you were doing Q# + * instead of * + Q#, that could be identified and addressed)

It looks like a pretty straightforward thing to set up, so the good news is it shouldn’t* be that hard to fix.

* May turn out to be incredibly hard to fix :stuck_out_tongue:

Centos 6.4

this is copied from one of the other WORKING queues except for changing of the name and now VoiceMail added yet.


Okay, so is your problem that with the SPIP 550, the queue doesn’t show up on the device…or is it that you can’t grab from it using a button press?

Yes! And eventually for that queue to show up in Asternic.

Yes the first one, I’m assuming…

That is all in your phone’s config then, under “Soft Keys” or something like that. Get your phone’s IP address (should be Menu > 2 > 2 > 1, if they’re the same as the 321 as far as menu goes) and enter that into your web browser. Look at how that’s configured, make a backup, test changes, revert if something breaks.

If you’re stuck, post screenshots of what you have questions about (edit out any private data such as a WAN IP address, phone number, usernames/passwords, or your adult-themed bookmarks :stuck_out_tongue:)

If you’re just inheriting it, I’m also curious as to what firmware the phones are running (Menu > 2 > 1 > 2 > 1, maybe?)

The ones I’m working with had a web UI that was plain HTML and missing a ton of features/fixes that made my life 100000% easier. Setting up a provisioning server was a bit of a learning curve, too. Another project for you maybe?

Pretty Cool that you can log into the phone like that!! I should have tried that earlier, I do that all day long with printers!! here is the FIRMWARE screen!

Now as for the queue part of my issue I am still at a loss. Am I correct when say that the screen shot I sent before, of the queue I created, is actually me using the GUI that is working over the LINUX server where FreePBX is located, correct? So that once I create the queue I do not need to do anything in “The Server” because the GUI is from the server, right? It just seems like I am not TURNING ON something or putting in a check-mark in the right spot.

Don’t know if this will help, but I just tried calling that queue(10600) directly and the phone hung-up. But calling the BILLING queue(10500) sent me to that queue and gave me hold music.

Check your line button configuration and try to replicate that with the new queue you added. The version you’re on looks like the nice JavaScript UI version, so at least there’s that.

Not sure why dialing your queue would do that, have you restarted asterisk at all since you added it?

Check your line button configuration and try to replicate that with the new queue you added. How do I do this?

No, I have not restarted this service. I haven’t had to but this might be different since it’s a new queue!

  1. In that web config, there should be something under utilities > line key configuration…I would imagine that’s what is allowing the phone to check the queue.

  2. I imagine that’s the case, but I’m not a doctor…also I have 0 experience with queues since our calls are all ring/voicemail :smile:

Thanks for all your help!! Not successful yet but i will keep trying!