I have a large network here that has subnets and VPNs that use the entire network range as well as some external SIP trunks. Now all my SIP phones have the NAT set to no. If I issue an externip= and a bunch of localnet= in the sip_nat.conf file I get no audio. Shouldn’t asterisk be ignoring any NAT settings if the device is net to NAT=no ?

My other question is there a way to specify the whole network range of for the localnet= setting? Would it be ? Otherwise I’m just putting a bunch of localnet lines with all the subnets I care about for testing. This is becoming cumbersome.


you should be able to do the localnet as you describe, And if you have nat=no then it should ignore the externip behavior. From what you describe though, it sounds like the nat=yes is getting aournd some of the ineternal network complexities which must be interferferring if nat=yes is the only way to make them work.

Transparent firewalls, DMZs, SIP ALGs in your equiement, etc. are the types of things likely to be creating problems and are common issues when dealing with complex network setups as you describe.

Seems like NAT=yes, no, or never works as long as I don’t specify any localnet. (externip is defined though.) Let me try one more time with the proper localnet settings and see.


OK now that I have the correct network address range I get audio. Even if NAT=yes the local net is overriding that setting like I’d expect.