Name/Username mismatch


#1

I have started having a strange problem. When I do a sip show peers, I see my listed users but some not all of the Name/Username are wrong. I am using distro 5.211.65-15 and have updated to asterisk 11.11.0.

Connected to Asterisk 11.11.0 currently running on hosted-pbx (pid = 403)
hosted-pbxCLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
1200/1200 D No No A 5062 OK (78 ms)
1201/1201 D No No A 5062 OK (96 ms)
1202/2004 D No No A 5062 OK (74 ms)
1203/1203 D No No A 5062 OK (76 ms)
1204/2302 D No No A 5062 OK (73 ms)
1450/1450 D No No A 5062 OK (34 ms)
1451/1451 D No No A 5062 OK (30 ms)
1452/2302 D No No A 5062 OK (34 ms)
hosted-pbx
CLI> sip show peer 1202

  • Name : 1202
    Description :
    Secret
    MD5Secret :
    Remote Secret:
    Context : from-internal
    Record On feature : automon
    Record Off feature : automon
    Subscr.Cont. :
    Language :
    Tonezone :
    AMA flags : Unknown
    Transfer mode: open
    CallingPres : Presentation Allowed, Not Screened
    Callgroup : 12
    Pickupgroup : 12
    Named Callgr :
    Nam. Pickupgr:
    MOH Suggest :
    Mailbox : 1202@default
    VM Extension : *97
    LastMsgsSent : 0/0
    Call limit : 2147483647
    Max forwards : 0
    Dynamic : Yes
    Callerid : "
    MaxCallBR : 384 kbps
    Expire : 1929
    Insecure : no
    Force rport : No
    Symmetric RTP: No
    ACL : Yes
    DirectMedACL : No
    T.38 support : No
    T.38 EC mode : Unknown
    T.38 MaxDtgrm: 4294967295
    DirectMedia : No
    PromiscRedir : No
    User=Phone : No
    Video Support: No
    Text Support : No
    Ign SDP ver : No
    Trust RPID : Yes
    Send RPID : No
    TrustIDOutbnd: Legacy
    Subscriptions: Yes
    Overlap dial : Yes
    DTMFmode : rfc2833
    Timer T1 : 500
    Timer B : 32000
    ToHost :
    Addr->IP :
    Defaddr->IP : (null)
    Prim.Transp. : UDP
    Allowed.Trsp : UDP
    Def. Username: 2004
    SIP Options : (none)
    Codecs : (ulaw|alaw)
    Codec Order : (ulaw:20,alaw:20)
    Auto-Framing : No
    Status : OK (74 ms)
    Useragent : Yealink SIP-T22P 7.70.0.130
    Reg. Contact : sip:1202@
    Qualify Freq : 60000 ms
    Keepalive : 0 ms
    Sess-Timers : Accept
    Sess-Refresh : uas
    Sess-Expires : 1800 secs
    Min-Sess : 90 secs
    RTP Engine : asterisk
    Parkinglot :
    Use Reason : No
    Encryption : No

I see the Def. Username: is set to 2004, but I have not configured this anywhere. I have tried to unregister the account and register it again. it it stays the same.


#2

Update:
Tried deleting the extension and adding it back. NO change. Any Suggestions?


(Roadrnnr1) #3

Old thread but I just wanted to leave an update for anyone else having this issue. We too had this exact same issue where names/usernames were mismatched. This caused 50% of the SIP Peers to become UNREACHABLE after a sip reload was performed. The SIP REGISTRY database had duplicate entries all through it and we concluded the astDB was corrupt. After correcting that issue everything worked again.

The root issue was moving our 5.211 installation to a new 5.211 deployment. Fresh install of 5.211 and then a backup restore caused the issue, I suspect the underlying asterisk versions between both boxes were different.