Mystery extension in pjsip

I tried creating a bunch of extension in FreePBX 16 and they all showed up fine. However, I have somehow added 3 extension with a 99 prefix. (eg: 99100, 99200, 99300 when I also have a 100 200 and 300 extension). In fact, extension 300 is ‘vritual’, so it should have a device (the ‘dial’ field in this table shows ‘PJSIP/99300’).

I can’t find how to get rid of these 99xxx extensions. By dumping the asterisk.devices table I can see the three extra extensions with ‘WebRTC’ prefixed to the description.

What have I done, and how do I get rid of these 3 extensions? I tried disabling webrtc for those extensions but it made no difference. I’m thinking of using a MySQL command to delete them from the devices table, but don’t want to mess up referential integrity in case someone says they are needed elsewhere.

These are the WebRTC shadow extensions. If you disable the ucp phone in user management, they will go away.

Why would only a few users have this? I don’t think I setup these users differently.

I went to:
User management > Edit user > UCP > Phone

Is this what you meant? The setting is currently “Inherit”. Should I set that to no?

They are part of a user group that has that enabled. If you created some extensions without a user attached to them or a user that’s not part of the same group then it wouldn’t be created for those extensions.

You can disable the feature at group level.

Strange, I had created 3 user groups and UCP phone was enabled in all of them. Not sure why only some users got this.

And, one of the extensions was using SIP type (which I had already disabled). There was no way to get rid of the extension from the GUI so I just deleted it from MySQL. Sounds like a bug.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.