Mysql root user not possible?

i just installed asterisk + freepbx from sangoma linux 7 ISO, later i was using freepbx on raspberry(raspbx) and in this i had a mysql root user and password. This was useful for many things, like create users with limited permissions or allow certains ips to remote login into mysql. i used this to remote login into asterisk database and read audio recordings table.
In Sangoma Linux 7, i tried every way possible, but the only thing i can imagine is to reset the mysql root password. I don’t know if this would be dangerous. The default user located at /etc/amportal.conf conains a mysql user and password, but can’t create users or give privileges.

Is there any way to accomplish this? thanks

The mysql root password on the Distro is blank, and is locked to the localhost. You should be able to access maria with just:

 mysql -uroot

Thanks, that solved the problem

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.