My 'Now What'

Thanks for creating the PiaF site, it’s very helpful.

The setup there shows configuring a system using zaptel. I’m using the current Asterisk Now (1.5) and FreePBX (2.5.2) w/an A400P. I am using dahdi tools (v2.1.0.2) and dahdi (v2.1.0.4).

When I run dahdi_cfg -vv I get

Channel map:

0 channels to configure

The A400P has 4 FXOs in it. Any idea as to what I should see? Currently I have 1 POTS line plugged into port 1 of the OpenVox A400P.


From the Linux command prompt, type dmesg | less and scroll through to see if the A400P is being recognized. You may not have the A400P drivers loading. If it is, then you may have to manually config /etc/dahdi/system.conf for the hardware configuration.

Yes, I found this test/check yesterday. I ran through the log file but did not find any error messages about drivers failing. Although I’m not looking at it right this second I believe it even noted that the card was configured for 4 FXO(s). Right now, I think I need a chan_dahdi.conf file which I do not have.

FYI, last night I upgraded the FreePBX to 2.7 but still no success.

looking at the log I see:

Freshmaker version: 71
Freshmaker passed register test
Module 0: installed – auto FXO (FCC)
Module 1: installed – auto FXO (FCC)
Module 2: installed – auto FXO (FCC)
Module 3: installed – auto FXO (FCC)

Found a Wildcard TDM: Wildcard TDM400P REV E/F (4 modules)

As noted it is actually an Openvox A400P.

Ran a ‘dahdi_genconf’ to create my dahdi-channels.conf - did this replace chan_dahdi.conf?

After a reboot I now have a whole lot more when I run ‘dahdi_cfg -vv’

Channel Map:

Channel 01: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 04)

4 Channels to configure.

Settings echocan for channel 1 to mg2
Settings echocan for channel 2 to mg2
Settings echocan for channel 3 to mg2
Settings echocan for channel 4 to mg2

OK, so where are these FXS coming from? I figured I could edit the dahdi-channels.conf but the first line in there says don’t hand edit this file. Where I can edit these files?

Does the ‘Channel 01: FXS…’ refer to FXS signalling? Some of the other posts/config files I’ve been looking at refer to FXO modules using FXS signalling while FXS modules respond to FXO signalling.

One other post refers to seeing 'RED" next to the FXO listing. In that post it was implied that this was the card recognizing the POTS line.

In yet another series of troubleshooting posts, someone referenced running a command on the Asterisk console that monitors activity. I tried that and then attempted to dial out and then another test of dialing in. At no point did anything show up in the ‘real time log’ This makes me think that Asterisk is still not seeing the A400P.

It’s a bit difficult trying to figure out what the real issue is. A lot of the posts I’ve been reading are 2-3 yrs old and I do not know if these are bugs that were fixed in newer releases or real problems. If anyone wants to chime in and point me in a better direction feel free.

I’m happy because I can now dial out but sad because I do not know (for a fact) what fixed it.

I believe the fix was when I made/copied the chan_dahci.conf.template

  1. cd /etc/asterisk
  2. cp chan_dahdi.conf.template chan_dahdi.conf
  3. rebooted the computer

Some important things to keep in mind were:

  • my system (Linux side) knew about my card, the dmesg showed details
  • some changes don’t show/take effect until after a complete shutdown/restart, just making a change in the FreePBX web/console page is not enough >> brainier people may be able to bypass this issue but if you are starting out just keep rebooting the box
  • I thought I would need to edit my chan_dahdi_custom.conf based on Step 3 at all that did was hose my system
  • I found a nice piece at PiaF on if you can’t run dahdi commands like ‘show channels’ in the Asterick CLI how to troubleshoot, since my system was running fine until I edited a single file I could recover fairly quickly.
  • the 'PBX in a Flash; website probably has all the answers you need to fix your box, unfortunately the information is all over the place so finding it can be difficult, I found the info I needed to fix my problem but it was in response to someone else’s question at FreePBX