MWI Issues Post Migration

I helped a buddy of mine migrate his Free PBX box a little while back and we’ve been having issues with MWI since then.

We upgraded the old box to the current version at the time and made a backup of the configs. We then moved the backup tar to the new server (running the same version of FreePBX) and restored. Everything worked fine except the MWI.

Initially, the symptom was that the MWI on the SPA phones would not illuminate when they received new VM. After dinking around for a while and trying to read everything I could find, I changed the voicemail setting from [email protected] to [email protected] That seemed to fix the immediate problem, so we didn’t worry about it.

One user is complaining that since the migration, her MWI won’t go out unless she deletes messages via the phone. It turns out she is the only person in the office who uses ARI, and if she deletes messages via ARI, the MWI stays illuminated.

I’m not sure if these are related or not, though I would assume they are. Does anyone have any suggestions?

As always, thanks in advance,

CAW

Does the phone have a WMI polling enabled/interval? Cause i don’t think Asterisk will tell that she’s got no more new VMs, it will only tell she’s got new ones…

The phone is a SPA962. I am unable to find anything re MWI polling.

I had spent a couple of hours on this one and then I found the post by sanjayws above. I spent some time trying to find where these setting were and wanted to give a detailed accounting so it might save someone time in the future…

I am using FreePBX 2.9.0.7 with Cisco SPA303 and Cisco 7940 phones attached.

In the Admin GUI, go to the Setup tab and then click on Voicemail Admin under the Basic section. Click on the Settings link at the top of the page. Scroll down to find the entry “pollmailboxes” and set this to “yes”. The default polling frequency is 30 seconds which means it can take up to 30 seconds for the MWI status to change. If 30 seconds is too long to wait, set the “pollfreq” field with the number of seconds that works best for you. You will have to reload your configurations for this to take effect. Be cautious because I have not tested the effects of system loading caused by setting this feature. It is entirely possible on a system with many phones and pooling frequency set too low could cause the system to become non-responsive. Proceed with caution.