MWI in 1.6.2 not working - possible sip configuration issue?

I’m sure that once again I’m missing something simple but I have had no luck getting MWI to work correctly with 1.6.2. Here is background:

FreePBX 2.7 (latest)
System was a backup/restore using FreePBX 2.7 on asterisk 1.4.x
MWI worked fine with 1.4.x

I know MWI has been rewritten in and I think it is because the notify is not being sent after the message is left. This makes me suspect that I have something in sip.x that is causing an issue but I have no sip_custom.conf, just the sip_additional.conf and sip_general_additional.conf.

MWI will work after about 30 minutes but there are these huge delays both for notifications and when all voicemail has been deleted. The app_voicemail.c code says a manager event should be sent after the message is left which should cause a notify to the phone. When doing a sip debug on the peer I do not see a notify message for MWI.

BLF works fine which also relies on notify so I know the phone is registered and communicating properly.

Any suggestions? Others having the issue?

I opened an issue on since there doesn’t appear to be any resolution. Issue #0017398.


I have the same issue. Asterisk MWI will not work at all. I can see there is a voicemail on FOP. But the phones do not register any voicemail that is left. I’ll keep an eye on the ticket Rob opened for a solution. I could not find anything on the internet. Unless someone already found out how to fix it, please post it here as well.

First of all, make sure the phones are set to subscribe to MWI. Now, I do not know how it happened but while checking the state of the extensions, using the Asterisk CLI command “sip show peer” followed by the extension number of the phone, I noticed=> [sip options: path replaces replace timer]. It should be set to=> [sip options: (none)]. I was not sure how to reconfigure this setting. I did the next easy thing. I deleted the extensions and recreated them. That did the trick and problem solved. MWI working again. I am still curious as to how the change that caused the issue came to be. Anyways I hope my solution helps someone.

The peers I’m having trouble with already have “sip options: (none)” when I look at the details of the peer. The bug I filed has been acknowledged so I’m guessing there is something to it.

Thanks for reporting a possible solution. I wish that would work for me!

I did look at the report you filed. The thing is that I had the same exact problem you did. For the sake of the argument unplug a phone. Now delete the extension of that phone you just unplugged from the FreePBX interface. Next, recreate the extension, password, voicemail the same as before. Plug the phone back. Once it reboots, give it a couple of minutes. Finally, call the extension and leave a voicemail. Did MWI work this time ? ? Just try it. I hope it’s worth a try.


I saw this same behavior with 1.6 and 1.8. The cause was subcribemwi=yes in the sip.conf setting for the peer/user. Changing this to no corrected the problem. with it set to yes, asterisk will only notify the device if it has a valid mwi subscription. with it set to no, asterisk will notify the device regardless.

hope this helps.