Mutlicast paging between Yealink T22 and Sangoma S500 not working

The Sangoma can page the Yealink successfully but going the other direction there is no audio. I cant figure out if it’s that the Yealink is not transmitting the audio or if the Sangoma can’t play it. No handset plugged into either phone at the moment but I know both phones work as they can call each other successfully with the speaker on.

I set everything up according to what the wiki shows. Wondering if this is a codec issue but the yealink is set to use G722 by default and I’m pretty sure the Sangoma works with that.

Any ideas?

Sangoma S500
Firmware ROM– 20:37:00)

Yealink T22

PBX Firmware: 10.13.66-14
FreePBX 13.0.163

Confirmed that the G722 codec is supported by the Sangoma s500

The Sangoma answers the page but it doesn’t play any audio. What else could this be?

Problem solved, but I’m not sure why. I didn’t have handsets plugged into either phone and as soon as I plugged the one for the yealink in it worked, despite having toggled both phones to speaker while testing. Also, once the handset is plugged in I can now page via the speaker phone again. Weird.