Music On Hold - Cannot create additional Music Category or Streaming Category

When I click Add Music Category and then enter a name for a new music category, nothing happens. I am asked to reload the configuration like something has changed, but when I refresh the page, there is nothing there. And the musiconhold_additional.conf remains the same. I can make adjustments to the musiconhold_custom.conf, but how would I reference the custom contexts in that file?

I’ve verified that asterisk is the owner of all directories under /var/lib/asterisk.

Is this a bug? Or did I hork up my install somewhere along the way?

Having the same problem here with FreePBX 2.6. Can’t add new Categories (Music or Streaming). Acts like there was a change, but nothing happens.

Any ideas???

I have tested the scenario on my FreePBX 2.6.0 and it works just like it is intended to do. I added a Music Category and it was added in the menu to the left as it should be, I went into Queues and selected the new Category.

I am running FireFox 3.5.5 when I tested this, what browsers are you running?

Thanks much for the feedback. Not experiencing the same here. I add the Category and it appears nowhere. I’m running Firefox 3.5.5 on MacOS X 10.6.2. I’ll try this on one of my Windows PC’s. I’m pretty sure I tried it using Safari on the Mac already.

I’ll keep plugging along until I figure something out. Being relatively new to Asterisk and FreePBX makes this a challenge. But I’m always up for a good challenge.

Really appreciate the user forums, and particularly the fact that someone from the FreePBX development team would respond to issues folks are having.

Thank you Mikael.

Well, tried this on multiple browsers and Operating Systems. It’s definitely an issue with either Asterisk or FreePBX 2.6 in my environment.

I did make one system change to solve the permissions issue with the AGI-BIN directory\scripts. I’m now running Apache as user:group asterisk:asterisk on my AsteriskNOW 1.5/FreePBX 2.6 system. But this did not have any impact on the MOH problem.

Still interested in any thoughts anyone has. If posting some logs might help, I’m willing to do this.

Thanks again to all.

Check that you have a directory call mohmp3 in /var/lib/asterisk, if not, create it and set owner to asterisk.asterisk, then try again

Just as I had figured this out, doing exactly what Mikael suggested, I came back to the board and see that Mikael had the answer for me.

This is the trick to solve this in AsteriskNOW 1.5/FreePBX 2.6

Create the mohmp3 directory as Mikael suggeted in /var/lib/asterisk and set the owner and group to asterisk. I did a chmod to 775 as well just in case, and then an amportal restart

It’s working now.

Thanks Mikael!!!

My asteriskNOW&freePBX was migrated to xen. some work with SQL and some another bugs are solved.
after updates from pbx web page I CAN NOT ADD MUSIC CATEGORY ON MOH, it was look like php&sql issue.
I tryed here-posted flow, but it wasn’t helpfull for me.
So I goes on “help desk” solution - reinstall. not all, only MOH.
and… it works! now i can add music category and use other MOH features.

to do this you must:

  1. go to freepbx web page
  2. module admin
  3. click on “Check for updates online”
  4. click on “Music on Hold” and check “Force Download and Install”
  5. click process… and you already know what to do.

must work immediately.
good luck!