Music on hold after upgrade missing and can't upload

I upgraded to the latest version FreePBX 2.9.0beta2.1 and now my music on hold files are no longer there. I’ve tried to add an mp3 but it does not show up either. Any ideas?

running CentOS release 5.2 (Final)


it’s a ‘read only’ setting so make reasdonly visible and allowed to be changed and then it’s down with the other System Directory configuration information, as a select box.

OK, I did that. Still not converting MP3’s or can I see my old music.

I decided to find some WAV files and upload them. It is very picky on which ones it will play. Any other suggestions, let me know.

It should convert most MP3s to wav files when you upload them, though you need mpg123 installed on your system to do that. (That’s always been the case).

There is a setting also for that that allowed for the very old behavior where we actually converted wavs to mp3 and let asterisk play the mp3s (which is a bad idea because then it has to transcode them in real time).

I experienced the similar problem.

2.9 upgrade overwrote the contents of my musiconhold_additional.conf.

It kept the classes, but replaced my custom mode with a file mode so I lost my streaming source.


can’t seem to find that in the Advanced Settings.

the default directory changed form mohmp3 to moh in 2.9, but the migration is not properly honoring the old default setting. We’ll be looking at that today, thought I had fixed it last week but the fixed turned out to be wrong.

You can go into Advanced Settings and change your directory to mohmp3 if that is what you were using and it should be back to normal (you may have to restart Asterisk, MoH sometimes takes more then a reload for such settings to be registered).