Multiple nics, one for phones, one for external connection and one for admin

i’m not certain it was freepbx, it might have been centos? But thats just a guess on my part.

Best not to guess. Just try it :slight_smile: .

Centos? Not latest Ssngoma?

Yes latest Sangoma - I seem to recall it mentioning centos somewhere in all the text scrolling by. arielgrin can address this more accurately as I’m pretty much a passenger on the troubleshooting. I can figure out the phone configuration, but not the linux part. I was moments away from buying the appliance but a vendor told me that the problems are similar when they do exist. so I might as well keep trying this platform.

I had mine running flawlessly on an old HP Proliant server that started to get flakey. They also take an eternity to boot so I migrated to an old PC and it’s fine and works very well for my business.

Thats what I’m hoping for. Lots of folks are using it, so I expect its going to be just fine, but I have to get this particular system running since thier meridian system died completely, Then once they are running I can try to poke at one for education. I poked at the last one to much and somehow broke it.
But thats how open source works right?

with Arielgrin’s help I have all the nics doing what they should using IPTABLES and the eth config files. Thanks again to him for all the patience dealing with my abundant supply of ignorance of the subject. The guys a saint.

I figured out how to make the 3750 switch that the phones and FreePBX box are all plugged into issue DHCP… and the phones all receive the IP correctly, hurray for me . . . but after configuring the extensions and mapping them, FreePBX will not issue the configuration to the phones.

I can ping the phones from the FreePBX box on the correct IPs, I can also reach the phones GUI from my workstation… so what can I have wrong where FreePBX wont send the config to the phone?

Provisioning should be straightforward as long as your DHCP server is configured to provide option 66 that should be set to freepbx’s IP. Then you configure endpoint manager to offer provisioning over FTP and that should be enough, given the right templates have been created for each phone.

The rest is done. The only part of that I cant be sure of is whether the phones receive the option 66 info. They get the IP, mask and gw just fine and the switch is set to send option 66 as seen below.

ip dhcp excluded-address 192.168.200.1 192.168.200.200
ip dhcp excluded-address 192.168.200.250 192.168.200.254
ip dhcp pool Phones
network 192.168.200.0 255.255.255.0
default-router 192.168.200.254
option 66 ip 192.168.200.200

a clue might be that when I look at the sangoma s500 phone/information/option 9, shows as the 4 characters @(HH and I would have expected an IP there.
Having said that, The first time I played with these I was still able to send the config from FreePBX once the endpoint manager has the mac address, without using option 66. 66 was just for rebooting the phones… or so I thought.

Sangoma phones should be even easier with their PnP autoprovisioning system, but I can’t help you there as I don’t own Sangoma phones. You should be able to get help directly from Sangoma as their phones include support as far as I understand.

I’m starting to think that option 66 needs to be a URL instead of an IP. But if true I cant use it as there is no DNS on this system. I don’t know if linux uses a hosts file like windows does.

But still, I was able to config the phones without using option 66 before so there is something else working here.

Option 66 is an IP to an TFTP server. You can only enter an IP, not a DNS name on option 66.

Good to hear - but those in the Cisco community disagree that’s the only option you can put there. The slots in the Sangoma GUI are all text entries back to Sangoma and that sorta reinforced the idea.
I think I’ll have to reconfigure IPTables to get updates through the maintenance lan as well as the public connection. the public one wont be online till I get this configured.

But I’m back at my day job this week so it’s back to nights and weekends for the phone project

Arielgrin
In case you didn’t see my other thread -
the command I needed in the switch DHCP server for option 66 was

option 66 ascii “192.168.1.200”

this sent the data formatted properly and all the phones took the configs on reboot.
Thought you might want to file that nugget away :smile:

Now I need to change the IPTables to allow updates through the business lan interface so I can keep work with this at home. I’m gonna look at my notes, but may request your help again on that. I may have the static IP for the SIP trunk by then too I hope.

Actually it is dependent on the phones you are using, polycoms require the quoted ip OR host, not so much with Yealinks or Aastras, all a bit of a catch 22, to solve that your DHCP server needs to modify it’s behavior according the mac address prefix of the client, DNSmasq works well for that as a dhcp server serving tftp. It is probably better to move to http which is less unfriendly, though a little insecure perhaps use https as it fixes most complaints, but you will need to fight your way through ssl ‘licenses’, (it’s worth it though :slight_smile: )

figures each phone model is different when that should be a standard. Thats just evil.

To further complicate my life, I did find a sangoma phone with a little earlier firmware that doesn’t have a slot for option 66. Doesn’t show on the phone gui at all. picked up the DHCP, but no config address slot. But thats one out of 15 so I’ll get to that one when I can.

Found that the reason it didn’t have a slot was a setting on the phone GUI. Populated it through its GUI and it became just like the others. Yay

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.