Multiple nics, one for phones, one for external connection and one for admin

Hope your holiday went well. At this moment none of the NICs are receiving IP’s -. I try to figure out what that is all about.
Cyberdocwi made a point that makes a lot of sense… as an “appliance” I have software fighting with the OS. Fighting is not the right word but this interaction between the application and the OS is why I am able to screw it up so easily. If I poke the OS directly the application isn’t expecting that to be possible so it gets angry.
I love the hunt, but I might have to buy the actual appliance to make this reliable for them.

You can do that if you feel more confortable, but it is completely doable. You can try to re-install, and the activation should pick your installation right away. In any case, why are you so worried about activation? Have you bought any commercial modules?

yes, I bought the startup bundle that was on sale for 1/2 off on black friday.
I have been trying to reorder the eth0,1,2 back to the order they started with using HWADDR in ifcg-eth0 etc and have had no success.

If the re-order happened after you modified something that you just can’t remember, you can always re-install. In any case, Sangoma should be able to help you right away.

Are you no longer able to assist - should i get these to take an IP?

I would love to help but if none of the NICs are getting an IP, there is no way to connect to the FreePBX server other than locally.

OK, I’m banging away at this. Kinda fun but I wish it was easier. Hang on a few, I have somethings left to try

OK I got in using the 3rd interface and putting a static IP into the ifcfg-eth2 file. how can we connect?

I’m about to have dinner now. If you got the server to catch an IP, just let it rest that way until tomorrow and I’ll be glad to help you.

ok (sad face)

MacsOffice can you post the result here please? I’m following. :slight_smile:

Sure. I have no objection to posting the dumb things I did if that saves the next guy. I’m an old dog and this is a new trick.

I’ve been in IT for 30+ years and I’m always learning. FreePBX was a new challenge to me a year ago and I couldn’t get one NIC working let alone two. I forget how I got around it, probably because at the time I did not appreciate the GUI allowed it through System Admin.

I’m an industrial IT guy. My tech is generally quite a bit older than IT folks are used to so the linux commands have a familiar tone to them but except for the occasional configuring of switches linux is a foreign beast that I should have paid more attention to. I’m old now so learning stings a little more:) .

1 Like

Let me know when you’re ready to share Teamviewer ID, send it by private message so it doesn’t get published in the general thread

pm sent

arielgrin I’m ready when you are

Tried again

Hey Ducktour
arielgrin poked at it for a long time and no matter what he did, it didn’t survive a reboot and the nics remained unhappy. I’m nearly clueless about linux but I watched his work and what I could understand was similar to what I could find on the wiki and google about configuring nics, some of it I had tried (ifcfg_eth0) and some I was afraid to but he wasn’t. (grub?) They just didn’t stay put as desired after a reboot.
So I reinstalled and we are starting from scratch with a whole new attitude :slight_smile:

Any files you change can be made immutable , which means FreePBX can’t change them, for example

chattr -i ifcfg_eth0

1 Like