Multiple ip addresses for trunk

Hello,

I’m using Asterisk Ver. 1.8.11.0 and I’d like to block Anonymous Inbound SIP Calls. When I click “yes” on that option, some of incoming call can’t be connected. Here is the copy of log file.

Executing [[email protected]:1] GotoIf(“SIP/203.254.210.84-0000003f”, “1?checklang:noanonymous”) in new stack

I am a newbie so I maybe wrong but it looks above call is coming from my SIP provider but it’s not in db. Thus call can’t be connected. My question is how to add that ip address into my trunk setting in below. Any help would be appreciated.

Outgoing settings
Trunk Name :samsung070-out
defaultuser=070xxx
fromuser=070xxx
callbackextension=070xxx
outboundproxy=proxy.samsung070.com
fromdomain=proxy.samsung070.com
host=proxy.samsung070.com
secret=xxx
type=peer
qualify=no
insecure=port,invite
context=from-trunk-sip-samsung070-out

Incoming settings
User context : 070xxx
secret=xxx
type=user
context=from-trunk

I don’t even know where to start.

You have so many needless settings in your outbound and an invalid context (won’t affect only outbound).

You don’t have a complete peer in your inbound. No host setting.

You need to have a trunk set to match the inbound. If you have a secret and a user don’t use insecure settings, insecure tells Asterisk to ignore authentication information in the invite.

It was copied from someone’s so i glad to know that there is room for improvement. Can you tell me which setting is redundant in outbound except insecure?

Thank you.