Multiple incoming call not work on GXW4104 and freepbx

I have a FreePBX system with a Grandstream GXW4104 using 2 analogue lines (connect from traditional PBX with extension 8495 and 8496). The Grandstream is registered and it works perfectly on outgoing calls.
On incoming calls it receives 1 call from FXO1 and transfers it to Ring group but it doesn’t accept any more calls on the other lines( FXO2,FXO3 and FXO4). The caller gets a ringing tone but no incoming call show on the sip phone. I can make outbound call normally in both 2 line.

Chan_Sip PEERS
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
901 (Unspecified) D No No A 0 UNKNOWN
902 (Unspecified) D No No A 0 UNKNOWN
906 (Unspecified) D No No A 0 UNKNOWN
GXWT1 10.18.30.194 Yes Yes 5060 OK (2 ms)
GXWT11 10.18.30.194 Yes Yes 5060 OK (2 ms)
gxw4104 10.18.30.194 Yes Yes 5060 Unmonitored
6 sip peers [Monitored: 2 online, 3 offline Unmonitored: 1 online, 0 offline]

I have a small server that running on Elastix and Zap16 voip card. I connect analogue line from traditonal PAPX to Elastix. But that server is very old and i need to build a new once. I select a Freepbx and Grandstream GXW4104.

Hi:
maybe you have to check the GS GUI setting. make sure FXO2,3,4 are in one group.

Current Asterisk Version: 13.19.1
I check Chan_PJSip Registrations and it show Status " reject". I don’t know that problem come from FreePBX or GXW4104

https://wiki.freepbx.org/display/FOP/Configuring+a+Grandstream+GXW-410X+Device+to+act+as+an+FXO+Gateway
I follow the Gui setting from Grandstream site, What can i do now ?

Try using chan_sip for the gateway. Verify that the parameter “unconditional call forward to voip” on the gateway is configured correctly for all the ports.

I reconfigure chan_sip trunk but i can’t receive all incoming call, i can make outbound call both 2 line. I just receive incoming call when i create pj_sip trunk.


I follow this guide, install freePBX 11. Create chan_sip trunk, and still get only 1 incoming call forward to Voip. Can i confirm that “unconditional call forward to voip” on the gateway is PSTN number ?

Are you expecting a second call on the same pstn line to roll over to a different line if one of your pstn lines is being used and somebody calls that same line?

For that to happen, your pstn provider must configure your lines into a hunt group.

Aside from that, you need to check that the unconditional call forward to voip is correctly set, that parameter is used to send the calls to freepbx. If you have an inbound route, you can use the number 7777, which by default is the feature code to simulate an incoming call.

Hope you have a nice day, arielgrin

Firstly, my english is not good, so sorry about that. Let me explain you the topology

Traditional FreePBX have 4 line analog with different extension (8491,8492,8493,8494) connect to GXW4104 and FreePBX. We set 4 extension in 1 one ring group 8999 in Panasonic PAPBX, when user call to 8999, it will forward to sip phone in FreePBX.

I guess something wrong with antivirus on my pc that using at company, because the Status off Sip Registration on GXW4104 is “No” but i try at home with the same setting on FreePBX and GXW4104 is " Yes". I will test it again when i back home and let you know. I will do manual FreePBX and GXW4104 when it work

I’m not sure I understood your topology. But it sounds as if the issue is with the panasonic.

Finally, It worked after install on real server ( Super Micro ). I guess McAfee anti virus on my pc block the connection between FreePBX (VM) and GXW 4104. All of incoming call and outbound call work well. But I need to create both Sip Trunk and pj chan sip trunk. At unconditional Forward to voip, User ID is set Ring group extension (ch1-4:600)

I will make manual, step by step how to Setup GXW4104 and FrePBX 13.

You don’t need to create two trunks, just one, pointing to the chan_sip port.

I will delete 1 trunk, and let you know the result

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.