Moved from HyperV 2012R2 to 2019 and boot doesnt give static IP anymore

Hi,
I have had a strange thing happen to a FreePBX 14.0.13.34 virtual machine running on HyperV 2012R2 for 7 months with no issues, now moved to HyperV 2019 and getting the following issue.

If the vPBX is rebooted (or shutdown and then powered on) it boots up with no IP address.
A quick work around I found was to boot with the VM NIC not connected to a network. Once its booted I login to the console and confirm the static IP is showing. Then change the VM NIC to the vSwitch that gives it its internet connection, and all works as normal.

Its a liver system so I didnt have much time to play with it in the failed state, but here are some things I tried. If anyone has anything else I could try please let me know.

We have the VM replicated to a second hyperV server - this too had the same issue.
We have nightly VM Image backups taking place, I found the work around before I got to the stage of spinning up the last nights backup, but nothing new was changed in the PBX so i don’t really think this would have given me a fix.

The VMs run on Dell PowerEdge Server with dual Teamed NICs brought through to HyperV as a vSwitch called WAN.
Booting the PBX with its vNIC connected to the WAN network it boots up with no IP. In the Current Network Configuration that appears when logging into the console, it shows ETH0 and only the MAC address.
If you check in the IFCFG-ETH0 file it has all the correct info for the static public IP address.
(if it makes any difference - a few weeks back I used to have a pfsence firewall in front of the pbx, so the PBX used to be an internal IP - I may change back to this configuration some night as a trial to see if it makes any difference).
I tried forcing ETH0 down and up and restarting the network service but still it had no IP address.

The VM is configured with a Static MAC address so the IP etc stays the same when it moves to a different Host.

As I said at the start, a quick fix is to boot it with the vNIC not attached to a network, and once booted, login to the console, confirm it is showing the static IP and then attach the network to the vNIC.

Over the next few nights I will try some things like
nmtui - to confirm the connection is activated etc
delete the vNIC and create new one with same MAC address
change back to the private LAN with pfsense edge vrouter
change from 1 vcpu to 2 vcpus
it has 4gb ram and 0 swap is being used
Worst case I can try to get it back onto a HyperV 2012R2 server.

I have 4 other (same version) FreePBXs and PBXacts running on the same HyperV 2019 hosts with no issues rebooting and losing their network.

I understand this is more of a hyperv centos issue but if anyone has any thoughts or anything else I should try please let me know.

Thx
Dave

Found the issue to be an old virtual router someone had powered on which used the same public ip address as the pbx.
the system went offline so via the console I was able to to a
sudo ifdown eth0
sudo ifup eth0

this then told me something else on mac add xxxxxx was using the same public ip address.
Hope it helps someone,
Dave

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.