Monitoring Parking Lots with Linksys SPA942

I am trying to get my buttons on my SPA942 to monitor my parking lot extensions. My basic setup is the first two buttons are line 1 & 2 for the extension, then I want button 3 & 4 to monitor parking lot 201 & 202. Right now all the functionality works like I hoped, if I park a call on 201, I can press the button and it will pick up the call. However, the light just flashes amber, and does not show the status of the parking lot.

If I issue sip show subscriptions, it says that I have 0. I have put the following in my line key function:

fnc=blf+sd;[email protected]$PROXY;[email protected]$PROXY

The server type is set to asterisk. But is there something else I need to do to get the buttons to register for the parking hints. If someone is parked on the extension and I do a core show hints, the parking lot shows InUse like it is supposed to. I just don’t know what I am missing.

I know this has to be a simple problem, still can’t figure it out…

Try changing the $PROXY to the IP of your Asterisk server.

Make sure that you have func_devstate.so loaded. You can check by going to the Asterisk CLI and enter show modules. If it is not there you will need to load it so the hints will work correctly. You can load the module in the modules.conf file.

I’ve tried replacing $PROXY with the IP address.

When I issue show modules or core show modules I get no such command

Try module show. What version are you running?

Oops, my bad. When i issue module show, func_devstate.so does show up in the list. Im running fpbx 2.7.0.1 and Asterisk 1.6. If the blf is working correctly then there should be a subscription listed in sip show subscriptions right? Is there a good way to test if this is working at all, or if it is just the call parking hints that I’m not able to subscribe to. Sorry for my ignorance i’m very new to this.

You can type show hints to get the status. You will see the park hints. If no calls are on these then they should show idle. If you have a call parked it will show inuse. If this is the case then all is working.

This is what I have for my SPA525g and it works fine.

fnc=blf+sd;[email protected]$PROXY;[email protected]$PROXY

I stuck with the default park numbers

Hmmm… I get the correct status updates, i.e. idle and inUse, it just that the lights don’t work. Maybe I’ll just start over and try again with the defaults. Thanks for your help I’ll let you know how it goes.

When you do a core show hints, and you look at the entry for park 71, is watchers set to 1 since you have a device subscribed to it. Also when you do a sip show subscriptions does it show up in there also? Just curious as to what I should be looking for if everthing is working correctly. And just to be clear, my call functionality works perfectly, its just the lights on the buttons.

In you phone make sure that you have server type set to asterisk, Also make sure to have the latest firmware in the phone. Latest is 6.1.5.a I tried this with my SPA942 and it work also.

The comment about devstate is not accurate.

The devstate module is not required for extension or parking lot hints.

Server type is set to asterisk, also I have 6.1.5(a) firmware. When I am checking the hints in the CLI should the number of watchers be 1 instead of zero? Also should it show up under sip show subscriptions?

Did you have to add anything to extensions.conf or any other conf file to get this to work?

The watchers will count as you add buttons to monitor the parking lot. What numbers do you see at the begining. Here is what I show.

[email protected] : park:[email protected] State:Idle Watchers 1
[email protected] : park:[email protected] State:Idle Watchers 1
[email protected] : park:[email protected] State:Idle Watchers 1
[email protected] : park:[email protected] State:Idle Watchers 1
[email protected] : park:[email protected] State:Idle Watchers 1

You should be watching that number.

Also make sure that you have this in your /etc/amportal.conf file.

USEDEVSTATE=true

I finally figure it out. Because of a previous configuration I had no settings on Ext 1 and the line was disabled. I moved the information from ext 2 to ext 1 and voila! I am just glad to find that my asterisk box is working fine. Hopefully this will be a help to someone else because it about gave me an aneurysm. Thank you to everyone that respondied.