Monitored calls not playable in CEL Reports

I’ve a fresh install of raspbx which is Asterisk 16.11.1 and FreePBX

For some reason I can not play recorded audio using the FreePBX CEL web page. My entries clearly show audio has been recorded and I have a playback widget that always shows 00:00 play time. Clicking the play button gets nothing.

The actual .wav files are saved in /var/spool/asterisk/monitor and when I transfer them with scp they will play just fine.

I initially thought this must just be something client side with my web browser (Brave) so I tried using Edge instead - with no extensions/noscripts/ad blocks, etc. I still couldn’t get it to work. Ok, maybe it’s a codec issue? So I tried my other Win 10 laptop with Edge and had no joy. I even tried Chrome on my Android phone and got the same problem.

Then I found using the UCP I could playback voicemails just fine in all the above browsers. The UCP appears to be using the same playback widget in which case I can rule out a browser config problem.

Ok, maybe it’s a file permissions problem? I logged into my raspbx and I can’t see any difference with permissions on the /var/spool/asterisk/monitor and /var/spool/asterisk/voicemail/default/extension/INBOX folders and files. ie. drwxrwxr-x asterisk asterisk

Ok, I am new to Asterisk/FreePBX and maybe there is something obvious I am missing but I can’t find anyone else with this problem except for this topic which isn’t quite the same, it looks like that chap didn’t have the playback widget at all on his inbound only calls.

raspbx is not a supported distro, and not maintained by this group. Have you asked at the raspbx fourms?

The browser’s developer console should give some clues, or possibly the web server error log (probably /var/log/apache2/error.log) or the freepbx log (/var/log/asterisk/freepbx.log).


Self-installed FreePBX systems are very much in discussion and supported by folks here.

1 Like

I know nothing about Brave, but confirmed that CEL recordings can be played with Edge, so probably not a browser issue.

There is apparently a bug in the playback widget – my system also shows 00:00 until the Play button is hit.

I looked at the network behavior in normal Chrome. There is a POST to /admin/ajax.php that returns the OGG filename, then a GET that retrieves the media.

1 Like

Not sure why you have taken this approach (instead of just contributing to the thread ), but:

Self-installed FreePBX systems…

Raspbx is not self-installed, but a distro located here:

and supported by folks here…

No way, that I am aware of, to reasonably keep track of who is a contributor to RasPBX on this forum, but that is besides the point as I said, “not maintained”, not not supported.

Lastly, while I have not stopped anyone else from helping drewfix, I maintain my suggestion of checking in the disto’s forum, like yours, is a reasonable (helpful) response.

I won’t comment further on this, other than to say have a good day.

I’m sorry I caused you offense. I simply meant to let him know that his question was acceptable here because we will gladly discuss FreePBX, whether Distro or self-installed, or installed using scripts or images from around the internet. It appeared to me you were implying that he should ask there and not here, due to the way his system was installed. I must have been mistaken. Without more detail, it does not seem like the issue would be specific to the Raspberry platform at all–it’s about FreePBX and the CEL module.


Ok guys, I’m afraid my thinking of there being a browser or php widget problem has been a bit of a red herring.

So far I have only been recording voicemail and my ‘Lenny’ virtual extension I forward victims to. The Lenny .wav’s are stored at the top of the /var/spool/asterisk/monitor folder in a simple 1234567890.12.wav number format.

I have since switched on recording of my proper sip extensions and now the playback works for these recordings which are stored in the /var/spool/asterisk/monitor/2020/ sub folders with a much more complicated name based on routing and date/time.

The CEL playback control appears to be trying to find the complicated version of the filename in these YYYY/MM/DD sub folders.

Since Lenny sets up the file name for the recording, you probably need to update Lenny to use the “new” directory structure.

That makes sense since that’s been the default structure for the past year (at least).

The problem this is solving is that the ‘monitor’ directory for the recordings was getting too big and affecting performance.

Thanks Dave. I don’t think Lenny sets up any filename for recording, in fact the simple script just plays back 16 files in a loop, listening for silence between. See crosstalksolutions Lenny instructions

Lennie recording started here

same =>  n,ExecIf($[${i}=1]?MixMonitor(${UNIQUEID}.wav))

you can change that without upsetting the rest of FreePBX

From elsewhere in extensions_additional

exten => s,n,Set(NOW=${EPOCH})
exten => s,n,Set(__DAY=${STRFTIME(${NOW},%d)})
exten => s,n,Set(__MONTH=${STRFTIME(${NOW},%m)})
exten => s,n,Set(__YEAR=${STRFTIME(${NOW},%Y)})

should get you going


dicko, thank you!
I find the asterisk scripting language a bit strange to say the least, I guess it must be stateless OLTP like old mainframe IBM IMS stuff. That is before my time, though I did implement Microsoft MTS at a previous job.

Anyway, I dug into the extensions_additional.conf for what’s what and found the following should work for Lenny or anything other recording in extensions_custom.conf

exten => talk,1,Set(i=${IF($["0${i}"="016"]?7:$[0${i}+1])})
;same => n,ExecIf($[${i}=1]?MixMonitor(${UNIQUEID}.wav))  --   deprecated since FreePBX 15
same => n,ExecIf($[${i}=1]?MixMonitor(${MIXMON_DIR}${YEAR}/${MONTH}/${DAY}/${CALLFILENAME}.${MON_FMT}))
same => n,Playback(Lenny/Lenny${i})
same => n,BackgroundDetect(Lenny/backgroundnoise,1500)

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.