MOH not working for parked calls

Hi all,

I am running asterisk 13.29.2 and Current PBX Version:
I have it so when a call comes through it goes to a ring group which the clients would normally put on park.
I currently have it set so ring group MOH is set to ring and the parked calls should have a stream going. Ive double and triple checked the stream which is fine. i even set it to default and still no music.
i saw in another thread that parking uses the same channel as where the call came from i.e ring group. Is this my problem? Do i have to stream the music through the ring group first in order to get MOH in parking?
The clients want the ring groups to have ringing though not music which is a dilema.
No good a custom configurations so if anyone has a solution would be so greatful.
Im new to Freepbx and asterisk

Thankyou in advance

I don’t think so, if you send them to the Park() application with the ‘r’ option.

Check the incoming route and make sure MOH is set to a correct option which has music within that group. The default is default which has music on hold already in when installed.

We like to do our changes Fridays so ill let you know if adding MOH to inbound routes fixes the issue. In the past i did have MOH set on inbound routes (which unfortuantely didnt resolve the issue) but was told that this creates a channel for the MOH which the parking wont use. As in the parking wont use the MOH because the imbound routes are using it.
If that makes sense, im fairly new to this so sorry in advance.


I wanted to see if the MOH was working at all.
So the MOH works fine, i can hear it if its set to a ring group or a queues but when the call is placed into park the MOH goes away. I also noticed that when dialling 700 (our parking number) it doesnt even give an announcement to say what park i am sitting in. However i do hear the beep when i pickup a parked call.
By any chance does this mean that no asterisk/freepbx audio is going into the parked calls. It seems the only thing i can hear is the person in park.

I spent a lot of time on this now and have changed countless settings and tried so many different things all resulting in no MOH in parked calls.

I even tried the suggestions in this just to see if i could get any results and nothing.

Post a call trace please. (Use pastebin)

sorry for no reply, have been away. It turned out that the “Parking Timeout (seconds)” was the issue. if it was set to high no MOH would play. As soon as i brought it down to 600secs it all started working again

In case no one from the dev community sees this, I think this should be reported as a bug. For me, at least, it violates the rule of least astonishment.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.