MOH instead of ringing?

I recently converted from a Trixbox install running inside vmware to running on the physical hardware (Gentoo) using freepbx 2.1.3.

When I was using trixbox, under the dialing options in the general settings module, I was able to set the “m” option, which caused the Music On Hold music to be played instead of ringing.

In freepbx 2.1.3, this does not seem to work. If I specify “m” in the options, I get silence during ringing. If I specify an “r” instead, I DO get ringing, however. Other than that, things are mostly working well. I’ve got small kinks to iron out, but I’m well on my way.

So, any thoughts on using MOH for ringing?

If you get silence, that means your MOH isn’t working. Usually caused by not having valid MOH files, or, not having a timing source (eg, ztdummy)


As it turns out, for some reason, * didn’t like one of my mp3’s. Weird that the trixbox installation i was previously running under vmware didn’t care about that particular mp3…