MOH - getting my file to play

This can’t be as hard as it seems. Yes, I Googled “FreePBX MOH”, but things have probably changed since 2011 and this has nothing to do with streaming.

I have a RasPBX install of FreePBX 2.11.0.0rc1.2 (Asterisk v11.5.0). I’ve successfully uploaded a 8kHz, 16 bit mono wav into “Category: Default” in “Settings -> Music On Hold” and deleted the other wav files that came with the install. Still, when I put a PBX extension (or an inbound caller from my GV trunk) on hold, they hear what sounds like a MIDI track. I want the wav I uploaded to be used system-wide in all instances that hold music would be played, but I haven’t found the way to point the system to it.

I’m using Grandstream HT-701 ATAs and an old Linksys SPA922, and since initiating the hold using either yields the same MIDI track to the phone on hold, my assumption is the music is being generated by the PBX rather than from an endpoint.

Can someone help point me in the proper direction? Thanks!

look at what directory is set in the advanced settings (moh or mohmp3) and then make sure you put your new wav file in the proper directory

Where in Advanced settings?

I’m looking at “Settings -> Advanced Settings” and I don’t see any thing regarding moh or mohmp3.

The same thing was mentioned in the forum posts I Googled, along with “enable hidden setting” or something like that, and I can’t find that either.

Thanks for the reply!

display readonly settings and override read only settings. you will see it in the directory layout area

“moh” was the setting and has my file in it. There are some files with .alaw, .g729 and .gsm extensions in the directory, but no .wav files except my own.

The “mohmp3” directory has 5 .wav files in it, none of them mine.

Switching the “MoH Subdirectory” in FreePBX to “mohmp3”, saving the settings and restarting doesn’t change from the MIDI I’ve heard all along.

What next? Thanks!

when you put an extension on hold? it should show you what is being played

How about some console logs of placing a call on hold.

2013-08-28 06:13:15] VERBOSE[1055][C-00000030] app_dial.c: – Called SIP/105
[2013-08-28 06:13:15] VERBOSE[1055][C-00000030] app_dial.c: – Connected line update to SIP/101-00000043 prevented.
[2013-08-28 06:13:15] VERBOSE[1055][C-00000030] app_dial.c: – SIP/105-00000044 is ringing
[2013-08-28 06:13:17] VERBOSE[1055][C-00000030] app_dial.c: – Connected line update to SIP/101-00000043 prevented.
[2013-08-28 06:13:17] VERBOSE[1055][C-00000030] app_dial.c: – SIP/105-00000044 answered SIP/101-00000043
[2013-08-28 06:13:20] VERBOSE[1055][C-00000030] res_musiconhold.c: – Started music on hold, class ‘default’, on SIP/105-00000044
[2013-08-28 06:13:33] VERBOSE[1055][C-00000030] res_musiconhold.c: – Stopped music on hold on SIP/105-00000044
[2013-08-28 06:13:39] VERBOSE[1055][C-00000030] res_musiconhold.c: – Started music on hold, class ‘default’, on SIP/105-00000044
[2013-08-28 06:13:45] VERBOSE[1055][C-00000030] res_musiconhold.c: – Stopped music on hold on SIP/105-00000044
[2013-08-28 06:13:49] VERBOSE[1055][C-00000030] pbx.c: – Executing [[email protected]:1] Macro(“SIP/101-00000043”, “hangupcall,”) in new stack

I’ll need the command for the CLI, remember I’m new to this.

My day job is a 3000+ extension TDM PBX with 10 PRIs and our own Office Code. This little RasPBX is a hobby. :wink:

One would think that if you run a telecom department of that size that you would be familiar with documentation.

You need to be familiar with basic Linux commands to view files and the logs that Asterisk and FreePBX generate.

FreePBX documentation is in our wiki.

Asterisk is at www.asterisk.org

how do you set the extension

while adding a new streaming catagory
the system asks for application
can application be file type “”.sh

the only thing i see related to music on hold in advanced settings
is Convert music files to wav TRUE/FALSE
below error is continuios in my log file

[2013-09-12 22:59:34] WARNING[21591] res_musiconhold.c: poll() failed: Interrupted system call