FreePBX | Register | Issues | Wiki | Portal | Support

Modules vulnerable to security threats have been automatically updated - framework has been automatically upgraded to fix security issues: SEC-2018-001


(Peter Richardson) #1

Hey Guys,

I am still getting the message of

Modules vulnerable to security threats have been automatically updated - framework has been automatically upgraded to fix security issues: SEC-2018-001

and I saw the solution was meant to be this:
fwconsole ma listonline && fwconsole reload

But this didn’t work for me, and I also read that it didn’t work for others, but I couldn’t find any other solutions, apart from “as far as I can see this issue is now resolved” without any further explanation. So I waited a few months for updates that might clear it up but it’s still not possible to hide/remove this notification. It keeps coming back. Any ideas?


(Peter Richardson) #2

hey guys, any ideas on what to do if that fwconsole command didn’t solve the problem?


(Peter Richardson) #3

any help greatly appreciated


(Dave Burgess) #4

Did you try clearing the error manually? Some of these don’t just “go away” - they have to be acknowledged from time to time.


(Peter Richardson) #5

Hi Dave, yes I have tried clearing the error many times from the dashboard by clicking the little (-) button but it keeps coming back.


(Itzik) #6

Try

fwconsole ma upgradeall

Then

fwconsole reload

(Peter Richardson) #7

it seemed to work at first, but then after I refreshed the page and that box by clicking “show all”, it was back again


(Itzik) #8

Did you try clearing it now?


#9

mysql asterisk -e 'DELETE FROM notifications'


(Peter Richardson) #10

Thanks very much Dicko, that was it! I refreshed, reloaded, etc and it didn’t come back. Many thanks to all here, greatly appreciated!!


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.