Modules Not Installing


I have FreePBX 2.7 running on my ubuntu machine with asterisk 1.6. I am having installing modules into freepbx.

I go to module manager and for example install Announcement, or Ring Groups. They say the install was fine.

I go back to the main page and click the link for the module in the left hand menu and then get a 404 not found page. This only seems to happen on some modules as I installed other modules with no issue.

I also notice I cannot see the module in /var/www/html/modules/ for the ones that will not work.

Is there anything I can do to get these modules working?


The most stable OS for Asterisk and FreePBX is Centos 5. Ubuntu is a good operating system but most people use Centos and FreePBX is designed for it. I suspect you are missing some of the libraries or other add-ins that are not resident in Ubuntu.

Also, I’d recommend a fully functional ISO that installs both Asterisk and FreePBX along with the operating system and required libraries. Check out PBXinaFlash, Trixbox and Elastix for just such an ISO. Even AsteriskNow will provide you with what you need.

If you want to run on Ubuntu, you’ll find most people do not use it and information to help you will be scarce or non-existent. I’d stay with the mainstream Centos 5.X in your situation.

Thanks, I somehow managed to get everything working 100% now :). I originally tried centos but had issues getting it running with it, I have no idea why but I went back to Ubuntu and found an install script and it just worked.

I am trying to do this on my VPS which gives me limited OS choices.

Anyway all is well for now, thanks.