Modules cannot be loaded


I am new to the forum and to freepx, asterisk too.

I installed the distro to a digium 110p card as below:

centos SHMZ release 6.5 (Final)
Linux 2.6.32-431.el6.i686 #1 SMP Fri Nov 22 00:26:36 UTC 2013 i686 i686 i386 GNU/Linux
Asterisk 11.7.0
DAHDI Version: Echo Canceller: OSLEC
PBX Firmware: 5.211.65-6
PBX Service Pack:

I use this system to interface a ss7 small switch with voip trunks
I configured chan_dahdi.conf and system.conf as using, but is not loaded, and this is working !? I do not find it from command " module show like libss7", while

localhost*CLI> module show like chan_dahdi
Module Description Use Count DAHDI Telephony Driver w/PRI & SS7 & MFC 1
1 modules loaded

It seems that ss7 is emulated from dahdi only.
Anyway, the point is that I like to try really libss7 and chan_ss7

After the distro is installed, I can find in a far directory, and copied it to directory of modules of the asterisk with the same owner and permission as other modules and after the load command I have:

Command ‘module load’ failed.
[2014-05-16 11:51:55] WARNING[11573]: loader.c:436 load_dynamic_module: Module ‘’ did not register itself during load
[2014-05-16 11:51:55] WARNING[11573]: loader.c:902 load_resource: Module ‘’ could not be loaded.

The was not in the system after the distro was installed so, I downloaded the source trunk, the “asterisk11-11.7.0-36_centos6.src.rpm” file from which I thought this asterisk is generated, unzipped it to usr/local/src and I followed the steps in .spec file for configure and make of this asterisk(not make install), and then I make the chan_ss7 from the trunk using this asterisk source, and obtained the that I copied to asterisk module directory with the same owner and permissions like all other modules and after reload of asterisk and tried loading of the module I got:

Unable to load module
Command ‘module load’ failed.
[2014-05-16 11:52:33] WARNING[11573]: loader.c:824 inspect_module: Module ‘’ was not compiled with the same compile-time options as this version of Asterisk.
[2014-05-16 11:52:33] WARNING[11573]: loader.c:825 inspect_module: Module ‘’ will not be initialized as it may cause instability.
[2014-05-16 11:52:33] WARNING[11573]: loader.c:915 load_resource: Module ‘’ could not be loaded.

I identified the identical version of asterisk in distro, I downloaded its source, I used the rigorously the same configure options found in the .spec file in source rpm, I tried different subversions of asterisk, but the problem persists.

Can anyone help me ?
how can I find what feature in configure is enabled or disabled wrongly ?

thanks in advance

Unfortunately in the distro we don’t support modification. If you feel a package is missing you should file a feature request under the Distro at