Modules are in cache folder but never update/install

Hello All,

Other techs connect to a server and update modules (in theory) and tell me they have updated this pbx.
When I connected today, I see the EPM critical update banner across EPM I click update and see it didn’t work, so I decided to check what was in cache and found pretty much what it looks like is people clicking download but not necessarily installing by clicking upgradeall.

I ssh to the box and look in /var/www/html/admin/modules/_cache/ and see all these modules in place from what I can only guess are download attempts, but not upgradeall. (list below)

At this point I figure I’ll just upgrade from command line:
fwconsole ma upgradeall ( results shown below ) and it wants to keeps talking about something older, rather than what available within cloud or in cache.

I then tried the localhost install, but it didn’t like that either, any suggestions?

Blockquote-rw-rw-r-- 1 asterisk asterisk 15904854 Apr 5 2018 endpoint-14.0.2.39.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 15912543 Jul 3 2018 endpoint-14.0.2.71.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 15273493 Jul 12 2018 endpoint-14.0.2.97.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 45496336 Oct 29 2021 endpoint-14.0.70.18.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 51018957 Oct 29 2021 endpoint-15.0.41.25.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 57152141 Mar 4 2022 endpoint-15.0.43.1.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 65026786 Mar 4 2022 endpoint-16.0.59.51.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 84916705 Jun 2 2022 endpoint-16.0.64.1.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 86607037 Dec 19 16:32 endpoint-16.0.69.10.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 86585029 Oct 22 2022 endpoint-16.0.69.7.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 86611280 Dec 10 2022 endpoint-16.0.72.2.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 86614324 Dec 24 2022 endpoint-16.0.72.6.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 86606892 Dec 4 2022 endpoint-16.0.72.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 86617190 Dec 31 2022 endpoint-16.0.73.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 92004969 Feb 18 2023 endpoint-16.0.77.1.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94583920 Apr 4 2023 endpoint-16.0.79.17.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94672103 Jun 10 2023 endpoint-16.0.80.12.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94665015 May 6 2023 endpoint-16.0.80.5.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94666603 May 13 2023 endpoint-16.0.80.7.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94665854 May 27 2023 endpoint-16.0.80.8.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94658090 Apr 22 2023 endpoint-16.0.80.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94729325 Aug 12 12:08 endpoint-16.0.85.3.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94735509 Aug 26 12:54 endpoint-16.0.85.7.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94737732 Sep 2 12:54 endpoint-16.0.85.8.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 95193370 Oct 7 12:22 endpoint-16.0.86.6.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 95205376 Dec 9 14:44 endpoint-16.0.86.9.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 94737205 Sep 9 02:55 endpoint-16.0.86.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 81057 Oct 29 2021 restapi-13.0.21.2.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 527161 Jul 3 2018 restapps-13.0.92.12.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 530141 Jul 12 2018 restapps-13.0.92.18.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 491232 Apr 5 2018 restapps-13.0.92.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 728058 Oct 29 2021 restapps-14.0.22.64.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 739125 Oct 29 2021 restapps-15.0.19.67.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 754208 Dec 25 2021 restapps-15.0.20.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 755278 Mar 4 2022 restapps-15.0.23.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1170218 Mar 4 2022 restapps-16.0.23.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1172143 Jun 2 2022 restapps-16.0.24.2.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1224977 Dec 4 2022 restapps-16.0.32.11.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1227835 Jan 12 2023 restapps-16.0.32.13.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1225422 Oct 22 2022 restapps-16.0.32.7.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1228440 Feb 11 2023 restapps-16.0.33.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1261969 Apr 22 2023 restapps-16.0.34.12.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1266750 May 13 2023 restapps-16.0.34.16.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1286003 May 30 2023 restapps-16.0.34.22.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1291727 Jun 10 2023 restapps-16.0.34.23.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1292898 Jul 9 02:48 restapps-16.0.34.26.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1292600 Sep 2 12:54 restapps-16.0.34.27.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1261114 Apr 4 2023 restapps-16.0.34.9.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1286895 Oct 7 12:22 restapps-16.0.36.1.tgz.gpg
-rw-rw-r-- 1 asterisk asterisk 1294045 Sep 9 03:05 restapps-16.0.36.tgz.gpg

fwconsole ma upgradeall
No repos specified, using: [commercial,standard,extended] from last GUI settings

Module(s) requiring upgrades: restapps
Upgrading module 'restapps' from 16.0.36.1 to 16.0.36.1
Downloading module 'restapps'
Processing restapps
Verifying local module download...Verified
Extracting...Done
Download completed in 0 seconds
Detected Missing Dependency of: endpoint 16.0.86.2
Downloading Missing Dependency of: endpoint 16.0.86.2
Processing endpoint
Verifying local module download...Verified
Extracting...Done
Module endpoint successfully downloaded
Installing Missing Dependency of: endpoint 16.0.86.2
Create symlink...Done
Checking database tables...Done
Migrating tables as required...Done
Checking Settings and Defaults...Done
Generating Configs...Done
Downloading Firmware...Done (Background)
Generating CSS...Done
Installed Missing Dependency of: endpoint 16.0.86.2
Dependency module endpoint  version 16.0.86.2 is Enabled
Unable to install module restapps:
 - <strong>EndPoint Manager</strong> module version 16.0.86.2 or higher is required, you have 16.0.69.10
Updating Hooks...Done
Chowning directories...Done
All upgrades completed successfully!
Updating Hooks...Done
Chowning directories...Done

try forcing the install:

fwconsole ma list
fwconsole ma downloadinstall module_name --tag version_number
fwconsole reload

Yes, I did try that and other methods.
Rest apps looks like it gets completed then drops this:
Unable to install module restapps:

  • EndPoint Manager module version 16.0.86 or higher is required, you have 16.0.69.10

So then you try installing 16.0.8x and all of them say they are not found, even though it’s right there.

fwconsole ma downloadinstall endpoint --tag 16.0.79.17
No repos specified, using: [commercial,standard,extended] from last GUI settings

Unable to update module endpoint - 16.0.79.17, it does not exist:

This happens for every version I see in the server within the cache folder.

Interesting twist, I received emails for multiple servers saying that EPM is being updated:
endpoint has been automatically upgraded to fix security issues:
SEC-2023-001

However I see multiple versions on these servers.
This server as well is still running the old version.

Make sure you have an active maintenance subscription for the commercial modules. (It can take up to 24 hours from purchase for the licensing server to sync)

Thanks for the response!

It does look like the EPM may have expired recently this is one of the newer installs, so I’ll have to double check dates, but are we saying that for a critical security flaw they wont update a module?

Additionally, we can see the downloads of the modules regularly but somehow not applied as well as the email saying its been updated because of the security issue but it really wasn’t.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.