Module Upgrades Failing

I have distro 1.818.210.58-1 and freepbx 12.0.1rc35. I am trying to update the free pbx modules but receive error messages like this:

Error(s) downloading timeconditions:
Unable to connect to servers from URLs provided:,

Any ideas please?

Go to advanced settings. Look for the word “caching” switch the setting. Go and check online


Thanks for that. I could not find caching in the advanced settings but I did change use wget for Module Admin to false and this worked, however, it is a bit strange because I have other systems behind the same firewall and they don’t suffer from this problem.

I now have one final challenge:

Installing sysadmin
Sysadmin RPM needs to be updated! Run ‘yum update sysadmin’ as root to continue Error(s) installing sysadmin:

Failed to run installation scripts

I ran yum update sysadmin but that said nothing marked for update

Again any ideas?

I’m having this same problem. I went to the advanced settings and turned the cache to false then tried again but I’m getting the error:

Downloading pbdirectory
Error(s) downloading pbdirectory: Unable
to connect to servers from URLs provided:,

I know my installation is getting a bit outdated but I’m a small company and my Linux is very limited. With no scripts for the update I’ve fallen behind. I plan to catch up once my mother finishes her chemo sessions next spring.

In the meanwhile, I"m on Asterisk and FreePBX