Module Upgrade Error

Keep getting an error saying:
Module(s) requiring upgrades: restapps
Upgrading module ‘restapps’ from to
but when I try to upgrade I get this:
Installed Missing Dependency of: endpoint
Dependency module endpoint version is Enabled
Unable to install module restapps:

  • EndPoint Manager module version or higher is required, you have 15.0.56

Well I do have 15.0.56 installed, but there is no update available???

Try fwconsole ma downloadinstall endpoint to reinstall EndPoint Manager maybe?

Nope. Just reinstalls 15.0.56. Reports no other updates.

Right, sorry. Once it’s reinstalled does fwconsole ma upgradeall still run into the same issue?

Same issue.

Oh jeez, sorry again. I miss read your initial post and versions that you have. Try the following:

fwconsole ma downloadinstall endpoint --tag=

Unable to update module endpoint -, it does not exist:

Huh, maybe something going on with the Module repository? I don’t have a v15 to test on but there is another thread going on currently where somebody else is having trouble updating some modules on a v14 system. Maybe somebody else here can corroborate.

If you’re paying for EPM, then ensure the maintenance is renewed. Updates require annual maintenance renewal.

I wondered if licensing could be an issue too. But, I have a 25 year license and only 9 months since purchased. So, should not be license issue, unless of course the licensing data is somehow corrupted. But no message suggests license corruption.

I have this issue all the time. If i renew any commercial module maintenance, it takes 24-48 hours for the PBX to “see” the update. Super annoying.

Actually waiting on one right now to install SangomaConnect, but restapps requires a newer EPM that I had installed, now im stuck waiting

1 Like

Have you guys tried going to Admin → System Admin → Activation and manually clicking on the Update Activation button?

Yes. In my case, It shows the licenses are up to date (correct expiration).

In my experience, the only solution is to literally wait for Sangoma’s license servers to update or whatever happens in that timeframe after module installation/renewal

Can’t say I’ve run into this before. Maybe setup a support ticket with customer care to look into for you?

Good advise all around. I will wait 10 days, if licensing issue does not disappear by then, will open a ticket. Issue is not impacting functionality.

I am getting the exact same error. I do have gold support active on my system and all of my other items are fine except with the endpoint and restapps issue you described. This is obviously some type of bug.

Thanks. Good to know. I like bugs. Better to be a victim of a bug, than a victim of our own stupidity.

1 Like

FYI, but now seems to have been captured and eliminated.

I am still getting the same erro as originally reported. My version is 15.0.5

Any other ideas?

Hmmm, I apologize. All I did was run fwconsole ma updateall and the EndPoint Manger rolled up to ver The module that was posing the issue then updated as well.