Module Update Fails with GPG Error - Unknown system error

Hi there,

I have installed AsteriskNow with Asterisk 12 and FreePBX 6.12.65-26. I am attempting to upgrade FreePBX modules but keep getting the following error for any module from the CLI or web interfacce:

amportal a ma upgrade webrtc

    Fetching FreePBX settings with gen_amp_conf.php..

    Found module locally, verifying...Redownloading
    Downloading 0 of 7356023 (0%)            The following error(s) occured:
     - Error opening for reading

I have tried “amportal a ma refreshsignatures” and “amportal chown” to fix permissions and settings but it has not helped. There is no furhter information in the log file nor dumped to the command line.

I have also tried as asterisk user:

gpg --list-public-keys 

pub   4096R/69D2EAD9 2014-05-05 [expires: 2016-05-04]
uid                  FreePBX Mirror 1 (Module Signing - 2014/2015) <[email protected]>
sub   4096R/CCEBF9CB 2014-05-05 [expires: 2016-05-04]

pub   4096R/B33B4659 2014-04-30 [expires: 2017-04-29]
uid                  FreePBX Module Signing (This is the master key to sign FreePBX Modules) <[email protected]>
sub   4096R/5C2FE148 2014-04-30 [expires: 2017-04-29]


gpg webrtc-12.0.3.tgz.gpg 
gpg: processing message failed: Unknown system error

Any help appreciated.

Happy 2016!

That means there’s a network problem somewhere between your machine and the mirror server. Try downloading it manually from the command line and see what happens?

Ok will give it a try. What are the steps to install manully? I donwloaded the webrtc module and placed it in /var/www/admin/modules/_cache and ran “amportal a ma upgrade webrtc” but still get the same error?


The problem is your machine itself can’t download it.

From the command line, run:

Paste here the error output.