Module: FreePBX Framework, File: /var/lib/asterisk/bin/amportal missing

Hey All,

Been running PBX in a Flash for a while and not had any issues. I wanted to try freepbx direct from the distro. After building a completely clean machine and going to the GUI, I get the following warning:
Module: FreePBX Framework, File: /var/lib/asterisk/bin/amportal missing

Looking at the OS, the file is indeed missing. I have done this install clean twice today just to be sure and Google doesn’t seem to be able to help.
There is another forum post about the missing file but the answer on that is to amportal chown which makes no difference on my system and the file is indeed still missing.
On the status page it says that the file has been tampered with.
I downloaded the distro today and did the asterisk 12 install.

Any pointers would be great.

Yup, there is definatly something wrong… I also did a re-install on my test box today, downloaded the FreePBX-Beta32 and got the exact same error…
tried to “amportal a ma upgrade certman” but no luck with that obviously … cuz amportal aint there…
suggestions svp

You can safety ignore the message It is not hurting anything.

“amportal” itself is not accessed from that location. It is run from sbin. I am confused by your error which is not related to this thread.

thanks andrew…
I was in the directory /var/lib/asterisk/bin at the time and I think I had a spelling mistake on the line anyhow…

but the overall question is : should I be concerned? after all there is a red warning screen on most of the pages within the Admin portal…

I will have this fixed later today. For now you can ignore it. The file gets moved from /var/lib/asterisk/bin/amportal to sbin which is why you are seeing that issue.

Thank you sir!
BTW I am still really impressed by the work that you guys do!

and with the speed that you guys find and fix errors / bugs / “features”…
and thanks again for the OTTS course that I had the privilege to attend in Phoenix!

1 Like

I’m the one responsible for this, and I can’t figure out how it’s happened. In the interim, you can copy the file /usr/local/sbin/amportal (or wherever it is) to /var/lib/asterisk/bin/amportal - the files are identical, and will match signature verification.

Secondly - when did you guys run an amportal chown, exactly? That’s when the file used to be moved (it’s now copied)

Tampered is possible BEFORE the ‘amportal chown’.

I preformed a distro update from the instructions on this link:

I have the same security issue saying a file has been tampered with and
"Module: FreePBX Framework, File: /var/lib/asterisk/bin/amportal missing"

I ran the distro update at 16:00 GMT today.

Andrew said we can ignore the error. xrobau, is this correct?

I also tried
cp /usr/local/sbin/amportal /var/lib/asterisk/bin/amportal

I did not get an error, but I still get the message. Have no idea how to find the missing file as am not really a linux guy and can only do the most basic commands by looking up everything on google.

100% correct.

Exactly correct again! All you need to do is ‘amportal a reload’ (or click on the ‘reload now’ button) and that error will go away.

i ignored the message on the status page… went for lunch… and when I came back I noted a couple of new updates were flagged… installed them and the red screen disappeared.

im fine now… and we may have just raised the red flag too fast… sorry!

Thanks. Restarted Amportal but the error remained. Anyway ignoring it if not a big deal. thanks for the fast support.

Thanks for all the info,
Glad I am not the only one seeing this. Just to give you an update in case it helps with tracking the issue.
I installed the distro clean on a brand new machine under vmware. The first time I logged into the GUI I had the error on the home screen about the module missing in the banner at the top and an error message saying 1 file had been tampered with on the status area on the middle right of the page.
Before you all replied, I tried the amportal chown command and it made no difference.
This morning I copied the amportal file to the correct place as listed above and then ran amportal a reload and it made no difference to the errors in the gui.
A reboot of the server also made no difference. I am going to update the modules that are now waiting for updates to be applied and see what that leaves me with.


Just patched the box with last nights modules and the issue disappeared.
Thanks a lot for the speed in resolution. My boss would not let me go live with a box that has errors on it :slight_smile:

Now to figure out how to get Joe on the box as the RPM has a load of dependencies and the yum repos don’t have it.