Modify VMX Locator to work when temporary greeting is active

VMX Locator does not work when we enable the temporary greeting. We use the temporary greeting on sick and vacation days when it is MOST important that we give options besides leaving a message. indicates that my observed behavior is by design, and also indicates that one of the posters made a fix.

Would anyone be able to help with a script that would keep VMX Locator working?

broswell, as per Philippe, please open a trac ticket (with a patch against trunk) so that we can try to include this in 2.9

I modified macro-vm in extension_additional.conf

I deleted the line:

exten => vmx,n,GotoIf($[(${STAT(f,${ASTSPOOLDIR}/voicemail/${VMCONTEXT}/${MEXTEN}/temp.wav)} = 1) || (${STAT(f,${ASTSPOOLDIR}/voicemail/${VMCONTEXT}/${MEXTEN}/temp.WAV)} = 1)]?tmpgreet)

I modified the line that was

exten => vmx,n(loopstart),Read(ACTION,${ASTSPOOLDIR}/voicemail/${VMCONTEXT}/${MEXTEN}/${MODE},1,skip,${VMX_REPEAT},${VMX_TIMEOUT})

to read

exten => vmx,n(loopstart),Set(RARMODE=${IF($[(${STAT(f,${ASTSPOOLDIR}/voicemail/${VMCONTEXT}/${MEXTEN}/temp.wav)} = 1) || (${STAT(f,${ASTSPOOLDIR}/voicemail/${VMCONTEXT}/${MEXTEN}/temp.WAV)} = 1)]?temp:${MODE})})

And I added the line

exten => vmx,n,Read(ACTION,${ASTSPOOLDIR}/voicemail/${VMCONTEXT}/${MEXTEN}/${RARMODE},1,skip,${VMX_REPEAT},${VMX_TIMEOUT})

immediately following the prior line.

Of course, after testing I moved the macro to the overide file

Bob Roswell
[email protected]

I would suggest opening a new feature request stating the options and use mode that you believe would be appropriate to set wrt to a temporary greeting so it can be considered when looking at future changes.

The closed ticket nor this post will be seen when the developers are looking at changes.