Mobile Bridging

We currently use FreePBX at our remote office, but – dare I say it - Druid - at our main office. This makes integration doable, but difficult. Within the next month supporting these boxes will fall upon me. However, I’d rather not have to deal with two different distros. In my opinion FreePBX has much more functionality so I’d prefer to standardize on it. There is one catch. I did some checking with the head cheese and as it turns out the primary reason they are using Druid at HQ is because of the mobile bridging function which allows an inbound call to ring both your desk and mobile phones concurrently, but if you answer the call on your mobile, you can transfer, park, etc., the call as if you are on your office phone. Is this doable in FreePBX, and if not, what would it take to make it happen.

More correctly, the call is not bridged (as in on a button of your office phone as well as on your cell phone after you answer) but uses follow-me to handle ringing two devices at once. I’m running FreePBX 2.5 and this feature is readily available as a feature of FreePBX and is independent of the Asterisk distro. Keep in mind that no Asterisk distro will allow you to answer on the cell phone, walk into your office and select a line appearance and bridge onto the call. If you pick up on the cell, you have to transfer it to park or back to the office extension to get it on that phone.

From the extensions menu, select one of your extensions and click on “Add Follow Me Settings” and you should see it. Enjoy.

I did think about that, but it doesn’t work. I set up Follow-Me to ring both my office extension and mobile phone concurrently. I then placed a call to my extension from an outside line. Both my extension and mobile phone ring. I then can answer the call on my mobile phone, but I can’t transfer the call using either ## or *2. All you hear is the tones, but nothing happens. Nor can I park a call. I went to our HQ and indeed it does work with Druid. With the same configuration while using Druid I press #1 on my mobile and it says “Transfer”, and I can then transfer or park the call. Am I missing something on PIAF in making it work?


I just tested the functionality and it works here with FreePBX 2.5 and Asterisk 1.4.11. Take a look at the FreePBX general settings tabs. I think you have to have both a “t” and a “T” in the asterisk dial and outbound dial command boxes.

The other thing I must ask, is the physical setup exactly the same at the PIAF box as the Druid Box. That is, do you have the same dial tone provider at both locations, same interface hardware, etc. I’ve seen instances where one dial tone provider does a better job of passing dtmf than another.

Looking at the PIAF logs while you are testing may provide some clues.


That was exactly it; the Tt option settings. Thanks VERY MUCH for your help — buy buy Druid, Hello PIAF throughout our company!!!

Glad to Help!!!

Good Luck.