Mitel IP Phone CF problem

I seem to be one of the few (maybe foolish) :roll: users of Mitel IP 52xx phones on asterisk. Its a nice looking phone but does seem to have issues. The problem I currently have is as follows:

  • any incoming call to a Mitel handset (5235, 5224 or 5212) rings on the phone for 5 rings and then on the 6th ring, the call gets transferred to voicemail. However, the calling party does not hear the personal greeting and it appears that the caller is transferred to a “communal” mailbox. External calls get greeted by “Comedian Mail - Mailbox?” and internal callers just get prompted for a password (and i don’t know the password)

There are no call forwards set and in FreePBX > General Settings, i have set “Number of seconds to ring phones before sending callers to voicemail:” to 999 (tried other setting too)

After a bit of playing around & ethereal trace, I discovered that the Mitel handset is initiating the forward to the location programmed in the phone’s “Voicemail Server Setting”. I have this set to *[email protected] I tested this by setting this to be another extension on the system and sure enough, the call is forwarded to this extension after 5 rings.

Now I have tested a SNOM 360 phone, a Nokia N95 & eyeBeam softphone and NONE of them have this problem. They just ring and ring and ring.

This isn’t always a problem, as we usually answer the phone before 5 rings, but when we don’t, people are complaining and asking what is “Comedian Mail”!!

So my question is two fold.

  1. Has any one else experienced this? If so, any advice / suggestions would be great.
  2. What is “Comedian Mail” and where can I change this prompt. Any ideas of some type of work around. (same behavior with ring groups)

Reading though your post got me thinking. There are two places in the mitel config that refer to voicemail. One in the user config page (Voicemail Server) and one in the advanced features page (Voicemail Retrieve Address). I had both set to *[email protected] but using your suggestion, I set the user voicemail server to my “extension [email protected]” and left the other setting in advanced features set to “*[email protected]”.
This way when after 5 rings, it forwards the call to itself (it still appears to do this as you can see the call disappear off the display for a moment) and and you can also get MWI and you can hit the message button to retrieve the message - i think this is the bit you were missing?

The XML is:

<voicemail_key>*[email protected]</voicemail_key>
<User State=“1” ID=“xxxx” DispName=“Kevin” Pwd=“xxxx” AuthName=“xxxx” Realm="" RegSvr=“192.168.x.x” RegPort=“5060” RegScheme=“2” ProxySvr=“192.168.x.x” ProxyPort=“5060” ProxyScheme=“2” VMSvr=“[email protected] VMPort=“5060” VMScheme=“2” OutSvr=“192.168.x.x” OutPort=“5060” OutCtr=“0” Ring=“1” Line=“0” EventSvr="" EventPort=“5060” EventScheme=“2”>
<voicemail_ringnum>99</voicemail_ringnum>

This last one that you mentioned, doesn’t appear to have any effect. I am guessing you found this too, if i am not mistaken, by what you are saying. Personally, I prefer using Call Forwarding to send calls to voicemail, rather than a hard coded setting that the end user can’t change.

Anyway, thanks for your help again.
Kevin

hmm,
I didn’t play hard but had never been able to get it to go to the voicemail server from the phone (which had its advantages or disadvantages depending on what you are trying to achieve). Where did you set that setting? Or … can you spit out your phone config from the gui (into the xml file format) and paste the relevant lines here?

as far as getting it to have freepbx determine when it should go to voicemail, you should probably just be able to remove that entry.

In my case, I have the entry in the user setup such as VMSvr="[email protected]" which allows it to subscribe and get voicemail notifications, but it has no resulted in the phone contacting the voicemail server after a number of rings (which I was trying to do at one point and used forwarding instead). I also vaguely recall a setting for telling it how long before it went to the voicemail server.

I think it was:

<voicemail_ringnum>4</voicemail_ringnum>